Uploaded image for project: 'Minecraft Realms'
  1. Minecraft Realms
  2. REALMS-3593

"Internal Exception java.io.ioexception: an existing connection was forcibly closed by the remote host" - Cannot get a stable connection to Realms



    • Bug
    • Status: Reopened
    • Resolution: Unresolved
    • PC-1.14.4, 1.15 (Java Edition), 1.16 (Java Edition)
    • None
    • None
    • Community Consensus
    • Java


      Moderator Note

      This report relates to users receiving this issue on Realms only, and can connect to other third-party servers just fine.

      If this is the case, and have potential information that can help this report, please leave a comment on this report - also, I would recommend visiting the Technical Support Resources as well, as they may be able to help you with your issue.

      If you have this issue on non-Realms servers as well, please visit the Technical Support Resources.

      I have been getting the "Internal exception java.io.ioexception: an existing connection was forcibly closed by the remote host " error on various realms, but specifically my own realm. 
      I have contacted and worked with the technical support resources, with them I have done these attempts to resolve the issue, but to no accord could they even seem to resolve the issue. 

      I have:
      1. Flushed my DNS.
      2. Changed my Ethernet Cable.
      3. Removed Norton.
      4. Removed Hamachi.
      5. Disabled my Firewall.
      6. Tried connecting to my modem via Hotspot tether.
      7. Triple Checked all Necessary Ports.
      8. Ran Malware and Adware Scans.
      9. Restarting my Modem/Router.
      10. Uninstalled and disabled my VPNs.
      11. Uninstalled and Reinstalled Minecraft in to an alternate location.
      12. Reinstalled and updated Java.
      13. Reinstalled Windows.
      14. Checked to see if my ISP was blocking connection to Azure (They are not as my wife is the Realm Host and using the same Modem / Router ).
      15. Reloaded the realm various times.

      After all these steps to no accord could I stay connected more than 5 seconds to 10 minutes until getting said error. 


        Issue Links



              Unassigned Unassigned
              Llen Llen
              41 Vote for this issue
              34 Start watching this issue