Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-20296

repeated use of /clone command causes redstone to stop updating

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 1.0.4.11, 1.2.8.0
    • Fix Version/s: None
    • Labels:
    • Confirmation Status:
      Confirmed
    • Platform:
      Windows 10 - PC
    • VSO:
      63208

      Description

      I discovered this bug while working with a simple T Flip-flop design which I was using to create a binary counter. When I cloned the circuit, I found it stopped working. Not only that, but some of the redstone, torches, and repeaters stopped updating altogether. I believe this bug is associated repeated cloning of redstone elements. For example, if a redstone which is powered is cloned on top of a redstone which is unpowered, the resulting redstone will no longer update.

      To test this theory, I did the following:

      • place a lever next to redstone dust
      • clone the lever and redstone to another location
      • turn the original lever on
      • clone the lever and redstone again in the same location
      • destroy the lever
      • now the redstone is powered, but there is nothing powering it

      I hope this is not a duplicate report, I searched the forum and didn't find anything!

        Attachments

          Issue Links

            Activity

              People

              • Reporter:
                rhp12345 Richard Preston
              • Votes:
                2 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  CHK: