Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-44589

Ridden boats not teleporting by @e

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: Minecraft 14w02c, Minecraft 14w08a, Minecraft 14w34d, Minecraft 1.8, Minecraft 1.8.1-pre3, Minecraft 1.9, Minecraft 1.9.1 Pre-Release 3, Minecraft 1.9.1, Minecraft 1.9.2, Minecraft 1.9.4, Minecraft 16w21b, Minecraft 1.10.2, Minecraft 16w42a
    • Fix Version/s: Minecraft 1.11.2
    • Labels:
      None
    • Environment:
      Windows 7
    • Confirmation Status:
      Confirmed
    • Game Mode:
      Creative

      Description

      Teleporting boats with @e is messed up.

      I was testing with the @e. I teleported different entities while I was riding them, with all but boats, I went with them.

      It teleported fine until I got in it. Then it just kind of sunk. I got out it still sunk. After disconnecting from the world it worked.

      To reproduce it:
      1. Set a command block to teleport an entity.
      2. Get in a boat
      3. Pull a lever that activates it
      4. It doesn't teleport like other entities.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                SuperModder101 Jace Crandell
              • Votes:
                13 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  CHK: