Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-103723

Unicode Doesnt Work On Add-On (UTF-16)

    XMLWordPrintable

    Details

    • Confirmation Status:
      Unconfirmed
    • Platform:
      Multiple

      Description

      > Summary
      On the latest beta : 1.16.200. There's new problem, Unicode doesnt work on Add-On. Usually Minecraft use ASCII or UTF-8 but most of my addon use UTF-16 to prevent code stealing.. even though its easy to decode it but worth to try.
      On UTF16, every alphabet dechipered as Unicode values. for example :
      a = +0061 or \u0061
      In Earlier version : 1.16.100.59, the unicode add-on still working finely until the 1.16.200 comes.. It breaks most of my geometry model that based on UTF-16 and it wont load even though there's no problem on the content log.

      >Step To Reproduce
      ~ Convert any .json files to Unicode using this converter
      ~ Save it and repack the Addon to .mcpack
      ~ load the unicoded pack into Minecraft
      ~ Set the pack at the global resources for better result (for Texture Pack)

      >Expected Result
      ~ Add-On component got loaded
      ~ Geometry based entity appear as intended

      > Observed Result
      Alright, i've been discovered this by taking a few hour to discover. First, because the unicode doesnt work on the latest beta, im just doing some test to do some decoding (revert back to utf-8). I just only decode the render_controllers because its the first thing i thaught "why the model isnt loaded and its just appear blank". Doing some decode on that, works greatly! my entity model back to appear as intended.

      Actually i have more than 1 addon, so.. im testing it on another add-on. Im curious if that would just affect one of my addon, but its seems not. On my second add-on, the entity model was also appear blank. Then im doing some decode again on the render_controllers.., weirdly its still not appear. My second thaught that comes in my mind is to change all the geometry file to utf-8. After taking some time, my add-on finally works again!

      >Actual Result
      ~ Geometry based model NOT loaded and appear blank
      ~ Add-On component NOT working as it should

      Note :{
      You can test it with my Add-On that based on Unicode : here

      >Update 1.16.200.57 :
      On the latest beta, the error now showed up at the Content log as the result of Unicode still NOT being loaded in this version and its causing Skeletal Hierarchy Index that was missing.

        Attachments

        1. Screenshot (39).png
          Screenshot (39).png
          1.02 MB
        2. Screenshot (41).png
          Screenshot (41).png
          1.02 MB
        3. Skeletal.png
          Skeletal.png
          724 kB
        4. SRound.png
          SRound.png
          1.34 MB

          Activity

            People

            Reporter:
            MC879 Kanzai
            Votes:
            3 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: