Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-64217

Entities and Blocks not updating/reloading correctly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 14w30c, Minecraft 14w31a
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows 8.1 (x64); Java Version 7, Update 45 (Build 1.7.0_45-b18)
    • Confirmation Status:
      Unconfirmed

      Description

      Quite frequently, upon leaving an area and then returning, entities and blocks (most visible with chests and the Enchanting Table) fail to resume their state properly/update the rendering engine... or something.

      The visual effect of this is quite bizarre: chests, when opened, seem to open correctly (the GUI displays and functions just fine), but a second chest model is in the same place as the working model and does not open. In other words, the appearance of the lid opening is working, but a second chest is visually apparent with its lid closed, within the other chest.

      The Enchanting Table makes this somewhat more obvious – the floating book animation that normally displays above the table when the player is out of its range (closed book slowly rotating) becomes "stuck" and stutters between one or two frames of the animation... while a second book model that functions as normal remains rotating as it ought to be.

      In addition, both of the above can occur multiple times, though it is only noticeable with the enchanting table, resulting in three or more of the visual models clipping into each other, remaining frozen. This can cause extreme lag when large numbers of chests are in one place; 10-12 chests are sufficient to cause significant lag. The duplicate models disappear upon quitting to the main menu and reopening the save file.

      I suspect, though am not certain, that it is related to another glitch whereby after digging or placing a block, sometimes the newly destroyed or placed block does not update the rendering engine until a block is placed or destroyed adjacent to it.

      I'll update with screenshots to make it clearer once I can trigger it again.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                vexx2ⁿ Joel Francis
              • Votes:
                3 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: