Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-36308

My animals still escape their pens, even when I use leads to keep them in.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.6.2, Minecraft 13w42b
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows 7
    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Survival

      Description

      The animals in my Single Player survival world keep getting out of their designated pens and into the other pens or just get completely stuck outside.

      When I looked at the 1.6.2 description I figured it was no big deal, but when I started playing the game my animals got out, completely contrary to the update notes. And today when I was playing in the latest snapshot: 13w42b, I put my many colored sheep on leads to see if that worked to keep them in place, and if so I would only take the animals off leads to breed them.

      As I went on to terra-form my world a bit, I came back to see if it worked and 3 of the sheep were in different pens, at least 1 was wondering in the vicinity of my house and all of them had broken their leads from the fences.

      During the updates/snapshots since 1.6.2 I've been keeping an eye on them, and the ones that escaped appeared to be stuck in the corner of the fence and when I'd come back later they'd be out of the corner fence block and wondering around my world.

      My set up was this: A large square fenced area with fences blocking through the middle of the squared. Cows in one corner, sheep in another, pigs in another, chickens in the remaining corner.

      I don't know if this bug affects other users but if it does there needs to be something done about it, because its really frustrating trying to get animals into specific pens only to have them escape later. The bug also applied to all the animals as will be shown in the screenshot in the attachment. I am also unsure if this bug is biome specific.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sparkyscah Joshua Sparks
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: