• Icon: Bug Bug
    • Resolution: Duplicate
    • None
    • 1.16.5
    • 1.14 threw 1.16.5 Java. I'm Running Optifine but still happens in vanilla Minecraft.
    • Unconfirmed
    • Creative
    • (Unassigned)

      I realize that this is more of a ongoing complaint in the community rather then a bug that is able to be isolated and removed, but I'll still put this here.

      I am creating a village that is under ground. When I first put villagers in it they weren't able to find the bell that was on the other side of the wall. Once I got them to see it they didn't go around the wall but instead tried to go threw the wall to find it, staring at it while gathering at a seemingly random point along the wall. (It was not the closest point to the bell, but was rather below it. This lead to many villagers looking up through a wall to try to get to a bell when they could have accessed it by going around the wall.
      When returning from their bed they took a path that lead to a dead end that was above their bed. I believe this was because of optimal path finding. The villager still claimed the bed because it could get to it but its path finding wanted it to go threw a wall and fall down a floor to get to the bed. I eventually fixed it by connecting a path to the bed.
      The first image below is about how a villager (The one in the center of the image, looking at the fletching table) would prefer to walk threw a fence and stand on top of a celling rather then go threw a gap to get to their work station.
      The second image is about a leather worker trying to get to his cauldron by walking threw a wall instead of taking a different path. The butcher is also doing the same thing.

      In general the villagers don't seem to be finding interest points when they are able to get to them, as well as not being able to find a path that actually takes them to the interest point.

      I have also noticed some strange behavior where Villagers that have a bed and know where it is, but stand on a cobblestone stair and look at a workstation even when it is night time. When I tried to block the spot they were standing at they just moved to another random place and kept looking at the workstation threw a block. There were multiple Villagers doing this. When I removed the block above the cobblestone stairs the villagers immediately returned to that spot. I killed the villagers that were doing this but new villagers kept doing the same thing. They are the last 2 screenshots. The villagers in the screen-shots have a path that is 15 blocks to the workstation(Fletching table). This behavior only seemed to affect a workstation in the corner, like this fletching table and the loom in the other corner of this area. This behavior continued all day, not being affected by villager schedule.

      I would suggest that the range for villagers to try to find a path be increased so they can navigate around a long wall and that what ever is making the villagers try to walk threw walls to get to things be fixed. Villagers seem to have a lot of issues in moving around a environment that is not a naturally generated village. Many of theses issues might be caused by optimal path finding, as there are no grass path blocks in my village.

        1. 2021-02-23_08.40.09.png
          1.89 MB
        2. 2021-02-23_08.44.16.png
          1.92 MB
        3. 2021-02-23_13.29.03.png
          2.04 MB
        4. 2021-02-23_13.29.17.png
          1.83 MB

            Unassigned Unassigned
            EpicTundra Lucas
            0 Vote for this issue
            1 Start watching this issue