Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-153997

Crossbow Multishot Backfiring 1.14.x+

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.14.2, Minecraft 1.14.3 Pre-Release 1, Minecraft 1.14.3 Pre-Release 2, Minecraft 1.14.3 Pre-Release 3
    • Fix Version/s: None
    • Environment:
      Java 1.8.0_51 Windows 10 (Updated June 2019)
    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Survival

      Description

      Duplicate created (154027) due to false resolution of this (153997) bug

       

      First, let me say that this is a 1.14 bug not exclusive to 1.14.2+, as I only found it now and cannot add previous versions even under the current branch version. New user to the bug tracker.

      Second, to properly document this bug, I would need a screen video recorder program, upon which I do not have.

      Now then, the bug. When a crossbow is enchanted with multishot, it will only ever work as if it was enchanted with level 1, as obtainable by survival methods without commands. A multishot crossbow will fire 3 projectiles, of which are normal arrows, spectral arrows, tipped arrows, and fireworks. To whom is reading this, I am not reporting another crossbow firework bug, as there appears to be plenty of those already. I am reporting a bug that affects (as many as I could test) 1.13 versions as well as 1.14 versions. Crossbows enchanted with multishot are designed to shoot 3 arrows, upon which I have seen they do. But when 2 or more (3) arrows hit the same large target, or are fired from too close a range, they reflect off the target, and "drop/reflect" back to hit the shooter. This works with plain arrows as well as tipped ones. I have not tried spectral arrows or fireworks, but I would ASSUME they DO affect spectral arrows and DON'T affect fireworks. From what I have seen, nobody has caught or reported this issue, which is surprising but I guess not everybody tried to hit multiple multishot arrows on the same entity.

      The Entities which are shot contain (but are not limited to) Pillagers, Iron Golems, Villagers, Ravagers, Vindicators, Witches, Zombies, and the Vex summoning (not vexes) Illager. I discovered the bug during a raid, and did minimal further testing. However, I tried using different 1.14.x and 1.13.x versions, and the bug remained. Shooting an entity with multiple arrows consecutively and ending up being shot by every arrow (1-2) aside from one is not a works as intended feature, and I have no idea what is causing it.

      To trigger the bug, Obtain by commands, creative, mob slaying, enchanting, or fishing + crafting, a crossbow with multishot, and thenfore get close enough to a mob to hit it with TWO of the three or ALL THREE arrows from the crossbow. I would recommend shooting a large mob such as the aforementioned Iron Golem or Ravager, and shooting whilst in survival to further prove the arrows aim back to and harm the shooter. The tipped arrows tested kept their tipped effects and applied them without any sign of changing intensity or duration to both the shooter when 'reflected' and the intended target.

      Low but annoying priority, reported June 6th 2019

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                LordNaturaliStar Bravewind
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: