Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-151804

Falling blocks that are passengers of falling blocks never land in 1.14

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Minecraft 1.14.1
    • None
    • None
    • Any world running in version 1.14 or 1.14.1 (not sure which snapshot if any this changed in).

      Tested in Java Edition on Window 10 with Java 1.8

       
    • Unconfirmed
    • (Unassigned)

    Description

      In Minecraft 1.13.x a command such as the following would result in the summoning of a falling block, with a passenger of another falling block, with a passenger of another falling block, with the passenger of a minecart command block.  When so summoned, the falling block would hit the ground and turn into a solid block (in this case, oak leaves), and it's passenger would land upon it, and also turn into a solid block on top of it (in this case, a redstone block), and it's passenger would land upon it and turn into a solid block (in this case an activator rail), and it's passenger would land upon it (the minecart would land on the activator rail, which is powered because it is on a redstone block, which would cause the command to run).  I am testing by running the commands from a command block, so that the falling blocks land on the command block.

       

       

      summon falling_block ~0 ~3 ~0 {BlockState:{Name:oak_leaves},Time:1,Passengers:[{id:falling_block,BlockState:{Name:redstone_block},Time:1,Passengers:[{id:falling_block,BlockState:{Name:activator_rail},Time:1,Passengers:[{id:command_block_minecart,Command:"say hi"}]}]}]}

       

       

      Similar commands worked in 1.12 (and 1.11 if modified correctly):

      summon falling_block ~0 ~1 ~0 {block:leaves,Time:1,Passengers:[{id:falling_block,Block:redstone_block,Time:1,Passengers:[{id:falling_block,Block:activator_rail,Time:1,Passengers:[{id:commandblock_minecart,Command:"say hi"}]}]}]}

      It also worked as expected when entities used the 'riding' tag, a stack of falling sand (as it was called at that time) would correctly fall and stack into a pile of blocks when you summoned a falling sand ridding a falling sand riding a falling sand, etc.

      In 1.14, this behavior has changed. The 1.13 command does work in 1.14, but the behavior is completely different.  The oak leaves falling block does hit the ground and turn into a solid oak leaves block, however, it appears the the passenger blocks are now lower or are inside the newly landed oak leaves block, and so don't land on the oak leaves block, and don't turn into a solid block. In this case, the redstone block and the activator rail 'pop' off the group of falling blocks as items.  Additionally, the command block minecart falls into the oak leaves, as if the oak leaves were pushed down into the mincart by a piston, without being broken by the piston (as would normally happen if a piston attempted to push leaves).

      This command, or ones like it, are used by a few external utilities to pack multiple commands into a single command block, by spawing multiple command block minecarts as passengers of a falling block configuration such as the one above, with each minecart containing one of the command to be run. This one summon command can then be run from one command block, but result in the execution of multiple commands, usually with the last few commands deleting the placed blocks and command block minecarts.  This can be done better with datapack functions now, but this technique existed and worked from before datapacks existed, and I don't see why it should have stopped working.

      This seems to be the opposite of issue MC-143894

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              TroZ Brian Risinger
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: