Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-121346

No sounds in this snapshot, 'Missing sound for event', (Silent mode)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 17w43a
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      OS: Ubuntu 17.04, 4.10.0-37-generic GNU/Linux
    • Confirmation Status:
      Unconfirmed

      Description

      When starting snapshot 17w43a, there is no sound. Version 1.12.2 (and other versions) work fine. The launcher logs that files are missing, as follows;

      Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
      [01:52:20] [Client thread/INFO]: Setting user: <<<NAME REMOVED>>>
      [01:52:22] [Client thread/WARN]: Skipping bad option: lastServer:
      [01:52:22] [Client thread/INFO]: LWJGL Version: 3.1.2 build 29
      [01:52:23] [Client thread/INFO]: Reloading ResourceManager: Default
      [01:52:23] [Client thread/WARN]: Missing sound for event: minecraft:ambient.cave
      [01:52:23] [Client thread/WARN]: Missing sound for event: minecraft:block.anvil.break
      [01:52:23] [Client thread/WARN]: Missing sound for event: minecraft:block.anvil.destroy
      [01:52:23] [Client thread/WARN]: Missing sound for event: minecraft:block.anvil.fall

      (snipping 544 lines, showing the same message for - presumably - all sounds)

      [01:52:23] [Client thread/WARN]: Missing sound for event: minecraft:weather.rain.above
      [01:52:23] [Sound Library Loader/INFO]: Starting up SoundSystem...
      [01:52:24] [Thread-2/INFO]: Initializing No Sound
      [01:52:24] [Thread-2/INFO]: (Silent Mode)
      [01:52:24] [Thread-2/INFO]: OpenAL initialized.
      [01:52:24] [Sound Library Loader/INFO]: Sound engine started
      [01:52:26] [Client thread/INFO]: Created: 1024x512 textures-atlas
      [01:52:27] [Client thread/INFO]: Narrator library successfully loaded
      [01:52:27] [Client thread/ERROR]: Realms module missing
      [01:52:33] [Client thread/INFO]: Stopping!
      [01:52:33] [Client thread/INFO]: SoundSystem shutting down...
      [01:52:34] [Client thread/WARN]: Author: Paul Lamb, www.paulscode.com
      AL lib: (EE) alc_cleanup: 1 device not closed

      I have tried completely reinstalling, with the same effect. There are no other errors; all files seem to have downloaded correctly - I can manually browse/locate the sound files and play them.

      Narrator works as normal, making sound. The /playsound says it plays sounds, but does not make sounds. F3 and T has no effect.

      I also tried the newer launcher (from http://launcher.mojang.com/staging/) and got exactly the same results.

      I removed everything (deleted .minecraft), reinstalled and rebooted between these attempts. Other versions work (1.12.2, 1.11.2, 1.10.2, 1.9.4), whether installed before or after this one. I tried (separately, fresh install again) adding a resourcepack which contained sounds, which had no effect.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              AnnieP Ann
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: