Uploaded image for project: 'Minecraft Realms'
  1. Minecraft Realms
  2. REALMS-267

Loading map at 4x scale sometimes causes realm to crash

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: MCPE-1.0.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows laptop, PE client

      Description

      When trying to fill explore a large map, under certain conditions, equipping the map from the quick bar caused the client to receive a "disconnected from server" message, and no players were able to log onto the realm for several minutes. This was (annoyingly) repeatable behavior.

      Steps to Reproduce:
      A little tough because I can't completely narrow down what triggered this bug. It did happen in multiple places on my realm. Also I didn't happen to grab the coordinates where the crash occurred, though I'll update if I can cause it again. The realm in question is called Tartarus and is the only one associated with the email address from which I'm reporting.

      1. Create a map at the maximum scale.
      2. Enter a problematic area, seemingly an area that has very very tall mountain features? That may be confirmation bias.
      3. Equip the map

      Expected result: Map shows white "self" marker properly, reveals more map.
      Actual result: Map marker doesn't move, map not revealed. After between 5-10 seconds, "Disconnected from Server" received.

      Other Debugging:
      1. Thought maybe it had to do with server maintenance, tried at different times of day, same result.
      2. Thought maybe it had to do with the game reloading after an original crash. Entered the game and waited for several minutes before trying map, same result.
      3. Thought that it might have to do with local terrain. Moving a small distance from where I experienced the crash didn't fix it, but moving a large distance did. This did correspond with moving away from a very large in-game mountain.
      4. Thought it might have to do with map scale. Creating a 1x scale map did work, though the 4x still triggered a crash. That said, 1x map didn't have a compass attached to it as I didn't have one handy.
      5. Original map had no copies. Did create a copy later, and still experienced the crash while exploring a large ravine area.
      6. Using the scroll-wheel to pass "through" the map on the quick bar was sufficient to cause the game crash. Removing the map from the quickbar entirely and walking around without ever equipping it stopped the game from crashing.
      7. At one point the "saved" point of my character during a crash had the map equipped. When the game loaded I quickly switched off the map to attempt not to crash the Realm, which was successful. It did appear to render the map for a moment, so I'm not sure what saved me from that crash.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jmmastey@gmail.com Joe Mastey
              Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: