Uploaded image for project: 'Minecraft Realms'
  1. Minecraft Realms
  2. REALMS-1106

Datapacks functions and tags unavailable on a realms world

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: PC-1.13.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      using windows 10 home and latest java version

      Description

      As there is no upload button on realms for datapacks, I downloaded my world and added my datapack as a regular folder (not a zip file, since zip files don't seem to be recognised as datapacks by realms) in the datapacks folder of this world. On a copy of this world, I tried out my functions and they worked just fine.

      Now I uploaded the world to realms and joined the game, but I found that non of my functions are available. It seems as if the game doesn't even know that they're there. I checked if the pack was enabled with the /datapack list enabled command and it was indeed enabled. The /reload command is not available on realms, so I disabled and reenabled the pack to try and reload it, but still the functions were not there.

      Steps to reconstruct:

      1. Make a datapack with functions
      2. place your datapack in a singleplayer world and make sure that it works
      3. upload that world to realms
      4. see that the pack is enabled, but the functions are not available

      In the attachement is the datapack that I used

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                D_Inventor Dennis Heutinck
              • Votes:
                3 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: