Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-93096

Remote user disconnected from Bedrock server

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Awaiting Response
    • Affects Version/s: 1.16.10
    • Fix Version/s: None
    • Confirmation Status:
      Unconfirmed
    • Platform:
      Windows 10 - PC

      Description

      I've setup a Bedrock server (1.16.02) that works on a whitelist basis which local (LAN) users are able to connect to but remote (WAN) users are unable to join (their gamertag and xuid have been populated within whitelist.json). The server log shows the remote user's gamertag as "connected" and then automatically "disconnects" them about 20s later, but provides no further detail. Within the game their player appears briefly at the spawning point. My WAN address is static and my router is set to forward TCP/UDP to port 19132 on the Bedrock server. Correct operation of the port forwarding has been confirmed with a port checker.

      This behavior is the same for multiple remote users, though one is able to successfully connect to the server which demonstrates there is not a fundamental issue with my router or firewall settings. Could the issue be associated with the remote user's Xbox One/Windows 10 Online Safety Settings and if so, what are the correct settings to allow server access?

        Attachments

          Activity

            People

            Reporter:
            pturner67@virginmedia.com Paul Turner
            Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: