Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-85069

Beacon UI doesn't update properly when changing effects

    XMLWordPrintable

Details

    • Bug
    • Status: Reopened
    • Resolution: Unresolved
    • 1.17.11 Hotfix, 1.16.0, 1.16.40 Hotfix, 1.16.101 Hotfix
    • None
    • None
    • Confirmed
    • Multiple
    • 306536

    Description

      I was trying to mine obsidian, I had my beacon set to Speed II so I went and set the beacon to Haste II using an emerald and went mining. When I came back, I tried to set the beacon back to Speed II but I couldn't. I realized that in the UI, the beacon was still set to Speed II, but I had the Haste II effect applied instead, so it wouldn't let me change the effect because it was "already set" to Speed II when it was actually giving me Haste II.

      What I expected to happen was:

      When I set the beacon to Haste II, the UI should've updated properly to that effect, and therefore, the beacon should let me set it back to Speed II.

      What actually happened was:

      When I set the beacon to Haste II, Speed II was still selected in the UI, even though it was giving me the Haste II effect, and it wouldn't let me set it back to Speed II because I can't set the beacon to the already selected effect in the UI.

      Steps to Reproduce:

      1. Open a level 1+ beacon
      2. Set it to any effect using any material
      3. You'll notice how the beacon gives you the effect you just set, but in the UI no effects are selected, because of this, you can "change" the effect that the beacon is giving you to that same effect, wasting the material you put.

      In my case it happened a little bit different because I had the beacon already set to Speed II before I updated my world to the first affected version (1.16.0.2).

      I can set my beacon to any effect, except Speed II, because in the UI, Speed II is selected and the UI doesn't update properly. Therefore, Speed II will always be selected and you can't change the beacon to the already selected effect, which should be the same that the beacon is giving you, but isn't.
      As you can see in the screenshots below, it's giving me Haste II, even though in the UI no effects are selected.

       

      Attachments

        Issue Links

          Activity

            People

              ItsSamuelLeon Samuel León
              Votes:
              7 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                CHK: