Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-61902

"Disconnected Due to World Corruption" Please help, this needs traction.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: 1.14.1 Hotfix
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed
    • Platform:
      Xbox

      Description

      I originally posted this to the Minecraft Forum on 1/15/19, and I'll be throwing my entire story here so that hopefully this issue can get attention and traction.

      This is going to be a rather long read, I'll include a TL,DR near the end.

      My close friends and I have been working on a survival anarchy/build-your-own-civilization Minecraft world for a little under a year. We started the map in March of 2019, and had been making pretty steady progress on our world until sometime near the end of October, leading into November. We stopped playing for a while as an update had made our game feel sluggish, view bobbing was all sorts of messed up, and our resource pack had stopped working. That, along with the fact that we were running out of things to do, made the 7 of us temporarily lose interest in our map.

      Recently (mid-December), my buddy west side 233 and I updated our Minecraft games to the latest version, and hopped back on the world to see if the game felt more stable, and to our surprise, it truly did. The view bobbing had been fixed, and the game no longer felt as slow as it did before. I then went out using my Elytra West to go and generate new terrain with the intent of finding bee nests so I could relocate some of them to our island. As I was flying around, my screen was filled with a pink and black checkerboard pattern, and I saw a line of text that read "Disconnected due to world corruption. Try reopening the world or restoring it from a previous backup". I figured this may have had something to do with the fact that I was generating new terrain, and was just a one-time occurrence, and I reopened the world and headed home. This was the first time I had ever seen this error. Over the course of the next following days, we kept receiving the error, and still continue to get it to this day.

      We have seen this error countless times now, and we are struggling to find any causes. Sometimes, it seems the simplest of things could force the world to close and hit me with the "World corruption" error. From the many many times that this has happened, we have not yet found any sort of pattern. There have been times where simply opening a chest will force-close the world, and other times where we can be flying around having a blast, and all will be fine.

      As one of my buddies put it, it seems to be "consistently inconsistent" with how the world closes.

      The game generally can run for about 15-40minutes before needing to be re-opened, or else I run the risk of the game telling me the map is "corrupted". However, there's been times where the game can run for hours without being "corrupted".

      That's a problem, as I tend to go AFK, and allow my friends to use the map as a small little server while I'm gone.

      I've gone ahead and compiled a little video, showcasing just exactly what happens a little bit before, and right as I get the error. Obviously, the video doesn't show anywhere near all the occurrences, or else the video would be 40minutes long. Here's the link: https://www.youtube.com/watch?v=mx4uvt1YQkw&feature=youtu.be

      Things to note that should be taken into consideration:
      -Map size is currently around 1.3GB
      -Map did not have any resource packs active during the time of the errors (all packs disabled, only active pack was the default one)
      -Map has been copied around 10 times (I make a copy whenever a big event occurs, ie; mass migration, massive project, the End prep etc.)
      -During the video, only the host (me) sees the checkerboard pattern as the game closes, every other player sees a blank dirt texture

      Things I have tried to resolve/isolate the issue:
      -Reinstall Minecraft (remove app data and everything, resync worlds)
      -Opening other worlds to see if it's an isolated issue with that particular map (it is)

      TL,DR: Our survival map that we have collectively spent over 600 hours building, keeps randomly closing ever since the most recent update, and we receive the following line of text. "Disconnected due to world corruption. Try reopening the world or restoring it from a previous backup". We have put up with this error for as long as we could, but it's just so darn inconsistent and irritating, it makes it hard to do anything fun/risky without the risk of the game closing due to supposed "corruption".

      As I used to routinely make backups of the world, I would be happy to restore it from a backup, only if the most recent backup wasn't so darn far behind...

      It would be nice for the 7 of us to enjoy our map again, and for this issue to finally be resolved.

        Attachments

        1. Error.png
          Error.png
          751 kB
        2. Grindstone.png
          Grindstone.png
          682 kB
        3. Menu.png
          Menu.png
          797 kB
        4. Menu2.png
          Menu2.png
          704 kB
        5. Problem loading world.png
          Problem loading world.png
          1.22 MB
        6. Splash Screen.png
          Splash Screen.png
          998 kB

          Issue Links

            Activity

              People

              Reporter:
              LMKemp Larry
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: