Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-42996

Xbox One S Controller not working sometimes on ASUS Zenpad Z8

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 1.9.0
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed
    • Platform:
      Android

      Description

      I'm using a bluetooth controller for my ASUS Zenpad 8 and it was saying incoreect pin or passkey, Problem is I can't add in a passkey so it doesn't matter if I know it or not unless I figure out how to. I looked it up on youtube and google and was directed to a force pair app and a normal bluetooth app. Neither of them let me put in the passkey but the force pair one let's me forcibly pair the controller.

      However, I'm having this weird issue nobody seems to know about. For some odd reason, The controller sometimes doesn't work correctly at all, But sometimes it works completely fine with no issues! When I connect the controller to minecraft(specifically, It doesn't do this for other games but it does make certain things not work correctly but nothing major).
      (Keep in mind that it does sometimes work fine) I connect it and the controls are flipped and some of them don't work at all! The one that I'm supposed to move my head with has the function of hit and use!! If I move it down it will punch and if I move it up it will use, I thought maybe the use function worked like this too one day and I was right!!!!! The menu button is one of the bumpers, Both bumpers will take me to the pause screen. A, B, X and Y work fine and completely normally when this happens, So does the joystick I use to move around. So I can move and jump but everything else is broken.
      The left bumper does not work at all, the right bumper will take me to the pause screen, The actual menu button seems to work as a menu button sometimes.
      Right and left trigger don't work at all, It's like they are completely not-existent and I almost forgot about them when I wrote this.

      This problem does not happen on any other games besides minecraft, I tested it because I was playing a game called Bomber Friends and I wanted to see if the controls were broken and did not work with minecraft.
      It worked fine with Bomber Friends and Maxim the Robot

        Attachments

          Activity

            People

            • Reporter:
              Steve25_ Steve Twentyfive
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: