Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-137721

creative_category doesn't exist anymore

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Resolution: Unresolved
    • Affects Version/s: 1.17.40.20 Beta, 1.17.30.24 Beta, 1.17.30.23 Beta, 1.17.30.22 Beta, 1.17.30.21 Beta, 1.17.30.20 Beta, 1.17.11 Hotfix
    • Fix Version/s: None
    • Confirmation Status:
      Confirmed
    • Platform:
      Multiple
    • ADO:
      590835

      Description

      Last beta (1.17.20.23) the 'minecraft:creative_category' component was updated to include groups and categories, and was able to be put on blocks.

      This weeks beta (1.17.30.20) seems to have completely removed this, possibly reverting to the old method (which excluded blocks), not sure why as there were no issues with the new method and if it could be added back that would be great.
      Update - 1.17.40.20:

      • This is now resolved, but there is an inconsistency between blocks and items, blocks use the 'group' object whereas items use the 'parent' object.

      Update - 1.17.30.23:

      • This update fixed the creative category for blocks but items are still using the old method

      Steps To Reproduce:

      • Download and start a world with the supplied pack and experimental features on
      • Observe that the 'Aluminium Ingot' item has no texture (despite it using vanilla the Iron Ingot texture)
      • Observe that nowhere in the creative inventory can you find the 'grunt:barrel_block' block and when given via command it has invalid textures (despite using vanillas barrel textures)
        • These features worked in 1.17.20.23
      • In the item and block files observe the new method (creative_category with both category and group strings) and observe the old method (currently commented out)
        • In the Aluminium Ingot file, Uncomment the commented components and comment the new method out and observe that the aluminium ingot now has a texture proper
        • In the Barrel Block file, comment out the creative_category component and observe it now has proper textures, though is still no where in the creative inventory

      Expected Results:

      • The 1.17.20.23 method is used rather than the old one

      Observed Results:

      • The 1.17.20.23 has seemingly been removed without notice in the documentation, breaking all add-ons that updated to the new method

        Attachments

          Activity

            People

            Reporter:
            Gruntastic Gruntastic
            Votes:
            9 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              CHK: