Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-110940

Texel Anti-Aliasing Not Functioning


    • Icon: Bug Bug
    • Resolution: Duplicate
    • None
    • 1.16.200, 1.16.201 Hotfix
    • None
    • Unconfirmed
    • Windows


      After 1.16.200 released with Renderdragon as the new engine used for all Windows 10 devices, Texel Anti-aliasing stopped functioning, resulting in pixelation of block surfaces and possibly distortion on sign text as well. I included images on the pre-1.16.200 Texel anti-aliasing and the current pixelation issue. I also have 1 image demonstrating the aliasing issue with sign text. 



      [I downloaded two RTX compatible resource packs to test it on a world of mines, and after testing both and removing them, anti-aliasing stopped working even though mines is set to 16 and previously it worked very well. Only this particular world is affected, no other worlds have lost their anti-aliasing function, and I tried to move the anti-aliasing slider back and forth to see if there was a change, but nothing changed at all. During the test with the RTX packs (the ones I used were "Kelly's RTX" and "Vanilla RTX"), I had switched the RTX feature on and off to see what the world would look like with it off, and I noticed there that with RTX off while I have the RTX resource packs on (I didn't have both on simultaneously by the way), I saw that anti-aliasing didn't function with RTX turned off. After this, I deleted both packs, and tried to refresh the world, but anti-aliasing was still broken. It appeared the two packs were still saved to the world even after I had deleted them (I think all worlds save resourcepacks that have been applied before), and perhaps the anti-aliasing issue also stayed behind. I really want to hear that this has a solution, or else I've permanently lost anti-aliasing function to my main world. I'm also currently unable to provide visual proof of this due to the inconvenience of not having screenshots of the world before the issue appeared, but if anyone asks for an image of something, I'll try to get one to show.

      UPDATE: Okay, so, turns out anti-aliasing does still work-ish, I noticed differences on the edges of carpets with 1 AA and 16 AA. However, the effect it has on walls and the ground appear to be faulty. I could still clearly see pixels buzzing when looking at the ground 45 degrees down as I walk, and I could notice obvious aliasing lines on walls of buildings as I move around, too. I'm pretty sure 16 AA would've prevented this from happening, or perhaps another issue was present. I added two videos on differences between AA16 and AA1, and if I assumed correctly that Anti-Aliasing 16 replaced Texel Anti-Aliasing, then Texel Anti-Aliasing isn't functioning correctly as shown in the AA16 video, pixels are still noticeably aliasing.

      Update2: I added a screenshot of really pixelated ground with Anti-Aliasing 16. I am 100% sure this sort of pixelation was not present before, and now it's been annoying me. I also added another one demonstrating how before I messed with RTX, rather than having a pixelated effect, the game blurs it instead, and that effect seems to be gone.

      Update3: Upon inspecting old screenshots of the world prior to the RTX testing, I can confirm that the blur effect is gone and in the BlurEffect2 image, you can clearly see that the ground in front is blurred as usual, but in the Pixelation image, it the blur is not present, revealing the horrific effects of pixelation. I'm not sure whether it's a bug with anti-aliasing, or another whole issue altogether. I'm running out of options now, and all I can do now is wait for a response. (The blur effect is called smoothing I think)

      Update4: I tested out multiple other worlds I have that haven't had RTX applied to them, and they also have the same issue. Close range mipmapping/anisotropic filtering simply doesn't work anymore. Long distance mipmapping still works, just not textures close to the player. This did not happen at all previously nor even after 1.16.200, it only became to occur after I had tried out RTX. Now I'm not entirely sure whether it is indeed an issue with anisotropic filtering, or that Anti-aliasing 16 doesn't work (I tested between AA8 and AA16 and there was no noticeable difference).

      Update5: I have a new conclusion. Texel Anti-aliasing no longer functions as the pixelation occurs with the individual pixels of blocks and not on the edges (which is what regular Anti-Aliasing deals with), and anisotropic filtering works properly. I don't know if Texel Anti-aliasing was removed, or if it just stopped functioning after I began using RTX and now my entire game lost its Texel anti-aliasing ability.

      Update6: I have finally tried to delete Geforce Experience, remove Nvidia settings that may have possibly interfered, and reinstall Minecraft (while saving the worlds), and creating a brand new world to test this. The issue persists and sign text is also affected by this problem as there's clear lines around letters and they flicker when I move around. I don't think it is any longer an issue with RTX, and rather an issue that appeared after 1.16.200. ]

        1. AA16Video.mp4
          7.50 MB
        2. AA1Video.mp4
          8.76 MB
        3. BlurEffect2.png
          378 kB
        4. OldBlurringEffect.png
          38 kB
        5. Pixelation.png
          354 kB
        6. SignTextDistortion.png
          237 kB

            3AlanKing3 Alan
            3 Vote for this issue
            4 Start watching this issue