Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-98559

Some signs will lose NBT data on reopening world in non-cheat mode when it has been editted by a commandblock!

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.9
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      vanilla
    • Confirmation Status:
      Unconfirmed

      Description

      STILL WORKED FINE IN 1.9-pre1,2
      I tested it in 1.9-pre1 and 2, it still worked perfectly fine

      -The title is a lot to take in, so use the setup below for the first time.

      Because of a previous fix, making signs placed by non-ops lose their NBT data (security fix), now there is a bug that affects already placed signs in a non-cheats world.

      • Use this command to get a sign with cheats on (enable cheats through LAN, or use NBT editor)
        /give @p sign 1 0 {BlockEntityTag:{Text1:"{\"text\":\"test\",\"color\":\"blue\"}"}}
      • Place the sign above a commandblock (standing or wall)

      -create 2 dummy objectives test1 and test2

      • set your score for both to 0 or whatever number.
      • put this command in the commandblock below and and activate it once.
        /blockdata ~ ~1 ~ {Text4:"{\"score\":{\"objective\":\"test1\",\"name\":\"@p\"}}",Text3:"{\"score\":{\"objective\":\"test2\",\"name\":\"@p\"}}"}

      =Review what will happen now:

      • The sign will have "test" in blue on the first line, your scores on the third and fourth line.
      • Next you close the world, and DISABLE cheats (NBT editor, or using the LAN feature or some other way.)
      • Reopen the world in non-cheat mode. Although the commandblock is updating only the LAST two lines, the first one has disappeared as well as the last ones!

      Video: https://www.youtube.com/watch?v=icx6-5V2OlA
      This explains it really well (no sound)

      Partial Log of the Exception:

      [17:36:25] [Server thread/INFO]: Generating keypair
      [17:36:25] [Server thread/INFO]: Preparing start region for level 0
      [17:36:26] [Server thread/ERROR]: Failed to load data for block entity Sign
      java.lang.NullPointerException
      	at aqn$1.h(SourceFile:99) ~[1.9.jar:?]
      	at o.a(SourceFile:156) ~[1.9.jar:?]
      	at o.b(SourceFile:124) ~[1.9.jar:?]
      	at ev.a(SourceFile:21) ~[1.9.jar:?]
      	at aqn.a(SourceFile:107) ~[1.9.jar:?]
      	at apv.a(SourceFile:108) [1.9.jar:?]
      	at ass.a(SourceFile:306) [1.9.jar:?]
      	at ass.a(SourceFile:83) [1.9.jar:?]
      	at ass.a(SourceFile:70) [1.9.jar:?]
      	at lo.f(SourceFile:124) [1.9.jar:?]
      	at lo.c(SourceFile:76) [1.9.jar:?]
      	at lo.d(SourceFile:91) [1.9.jar:?]
      	at net.minecraft.server.MinecraftServer.l(SourceFile:325) [1.9.jar:?]
      	at byn.a(SourceFile:114) [1.9.jar:?]
      	at byn.j(SourceFile:130) [1.9.jar:?]
      	at net.minecraft.server.MinecraftServer.run(SourceFile:427) [1.9.jar:?]
      	at java.lang.Thread.run(Thread.java:745) [?:1.8.0_74]

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                m124367 Melvin Schop
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: