Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-98193

Sound channels not being handled correctly under certain circumstances

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.9 Pre-Release 3, Minecraft 1.9 Pre-Release 4
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Windows 10 Pro x64 Build 10586.104
      Minecraft Launcher 1.6.59 on Java 1.8.0_25 x64
      Video recording software is XSplit Broadcaster

    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Creative

      Description

      Video 1: https://youtu.be/Umry_VIw2eA
      Video 2: https://youtu.be/OnYsRr4rnI8

      I originally posted this issue as a comment on MC-36030, but although it could be related I now believe this to be a separate issue.

      There is an issue with the sound engine in the 1.9 prereleases (tested on 1.9-pre3 and 1.9-pre4) where sound channels (in this case, music channels) will not get unloaded in specific circumstances. In the first video I encountered it quite by accident, but in the second video I figured out how to make it happen with music channels. Here are the steps to reproduce it using music:

      1) Open any Minecraft world and wait for a song to begin playing
      2) Wait 20 seconds (ish) before exiting the world
      3) Menu music should immediately begin to play
      4) Go back into the same world and you will notice that the music will immediately start again, stop, then start over
      5) This music channel is now bugged. You can pause the game or exit the world and it will continue to play. Additionally, the music slider will not work on it

      Also in my first video, I somehow managed to get the guardian laser sound to behave in this manner by using a /kill command near a guardian temple. That proves that this issue does not specifically affect music.

      I have linked the log produced by messing around in the second video, which I set to development mode (so it logged changes in the sound channels).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                exhelah iamanai
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: