Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-83893

Crashes when connecting to server in 15w31b

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 15w31b
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Widows 7 64-Bit, Java Version 8 Update 31 (build 1.8.0_31-b13)
    • Confirmation Status:
      Unconfirmed

      Description

      I am running the 15w31b Snapshot jar on my server and I get the error message showed in the attached screenshot. I had the same error when connecting in 15w31a and thought it had been fixed in b, but the error still occurs.
      Everything appears to be going fine at first, it says Logging In, then Downloading Terrain, then the error pops up.
      In the console, it simply says I joined and then left all in the same second with no errors occurring there.
      [10:51:00] [Server thread/INFO]: jpdude98[IP] logged in with
      entity id 55 at (-1367.7826059092506, 108.5, -1310.0645640644007)
      [10:51:00] [Server thread/INFO]: jpdude98 joined the game
      [10:51:00] [Server thread/INFO]: jpdude98 lost connection: TextComponent{text='D
      isconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, i
      talic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null,
      insertion=null}}
      [10:51:00] [Server thread/INFO]: jpdude98 left the game
      Also, I am running a world generated in 1.8

      UPDATE
      I did some more research and people said that signs was the problem.
      So I just tried logging in again, but I had a command to teleport me to the middle of nowhere where there wasn't any signs and I am on the server with no crash! I then tried to teleport back to an area with a few basic signs and the game seemed to work fine there as well. It wasn't until I encountered some signs I made with lots of colors and commands on them that I got the same crash message again.
      It appears that the issue only arises when dealing with signs that have lots of data besides normal text attached to them.
      I just did a setblock command with one of these fancy signs, and it immediately crashed the server. So that is for sure the issue.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jpdude98 JP
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: