Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-81879

RCON is not listening on port.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: Minecraft 1.8.7
    • Fix Version/s: Minecraft 1.10.2
    • Labels:
      None
    • Environment:
      OS X 10.10 Yosemite, possibly others
    • Confirmation Status:
      Unconfirmed

      Description

      Hi!

      I noticed that sometimes, when I tried to connect to my Minecraft server via rcon, the connection failed. After getting the same problem a few times I began to test and tried to pinpoint what was different when it works and when it does not.
      I wrote a simple script to start the server and stop it via a rcon connection. After some time and a seemingly random number of succeeding iterations of this script, the rcon connection fails. I then checked the Minecraft startup log (attached): everything normal.
      Then I checked if the Minecraft server process was listening on the rcon port, but "lsof -i:25575" showed me no process listening on that port, although the server log says it is.
      I can reproduce this with different ports on two different machines running OS X. The same script is running on my Ubuntu Server at the moment, so far I am at 1000 iterations and counting (1000 starts and stops via rcon) without any issues. So this seems to be OS X specific.

      Since there is no error in the log, the Minecraft server does not seem to realise that the start of the rcon service failed.

      latest.log
      [17:32:45] [Server thread/INFO]: Starting minecraft server version 1.8.7
      [17:32:45] [Server thread/INFO]: Loading properties
      [17:32:45] [Server thread/INFO]: Default game type: SURVIVAL
      [17:32:45] [Server thread/INFO]: Generating keypair
      [17:32:45] [Server thread/INFO]: Starting Minecraft server on *:25565
      [17:32:45] [Server thread/INFO]: Using default channel type
      [17:32:46] [Server thread/INFO]: Preparing level "world"
      [17:32:46] [Server thread/INFO]: Preparing start region for level 0
      [17:32:47] [Server thread/INFO]: Preparing spawn area: 85%
      [17:32:47] [Server thread/INFO]: Done (1,293s)! For help, type "help" or "?"
      [17:32:47] [Server thread/INFO]: Starting remote control listener
      [17:32:47] [RCON Listener #1/INFO]: RCON running on 0.0.0.0:25575
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              rstein Roman
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: