Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-67704

Chunks not loading properly in previously created worlds. Massive Chunk Updates.



    • Bug
    • Status: Resolved
    • Resolution: Fixed
    • Minecraft 14w32c, Minecraft 14w32d, Minecraft 14w33a, Minecraft 14w33b, Minecraft 14w33c
    • Minecraft 14w34c
    • None
    • Windows 7 (64bit)
      Windows 8.1 (64bit)
      Java 7u67
      Java 8u11
      Single Player
    • Unconfirmed


      Around 14w32c, I noticed that chunks would not load on my world until I or another player entered them. This world has been actively played on a snapshot server since the start of the 1.8 snapshots, and gets updated on ever snapshot release. No modifications have been made to the world file, no third party mods are used.

      At first, I thought it was an issue with my (Windows 7, Java 7u67) server. I attempted to correct the issue with hardware/software troubleshooting. No resolution.

      I copied the map to my laptop (Windows 8.1, Java 8u11) and fired it up in single player. Same issue.

      Chunk updates appear to be stuck in the upper 200s and lower 300s while looking toward positive coordinates. Turning toward negative coordinates will quickly drop the chunk updates to 0 - 40 and load the chunks in that direction, but still not the chunks toward positive coordinates. Pausing the game (in single player) by use of the inventory, book, or ESC menu will force the chunks to load and drop chunk updates to 0, but unpausing the game will cause chunk updates in the positive directions to shoot back up to the upper 300s. I have tested this at multiple coordinates in my world, and the issue persists at all of them.

      I then assumed, my world was subject to corrupted chunks. But I took another troubleshooting step before settling with that (unbearable) reality.

      • I loaded the exact same world in 14w31a. It was perfect, loading was great, chunk loading was between 0 and 25.
      • I loaded the exact same world in 14w32a. It was perfect, loading was great, chunk loading was between 0 and 25.
      • I loaded the exact same world in 14w32b. It was perfect, loading was great, chunk loading was between 0 and 25.
      • I loaded the exact same world in 14w32c. And it hit. The world was not loading chunks in what appeared to consistently be the negative X and Z coordinates. Rolling back the issue to 32b fixed it, rolling it forward again made it reappear.

      Something between 14w32b and 14w32c is causing my world to get hung up on chunk loading toward positive coordinates, and refuse to load chunks unless I look toward toward negative coordinates, physically enter the chunks, or PAUSE the game via inventory, book, or ESC menu.


        1. 2014-08-16_08.38.26.png
          1.89 MB
        2. 2014-08-16_08.40.16.png
          2.23 MB
        3. 2014-08-16_08.41.30.png
          1.35 MB
        4. 2014-08-16_08.41.47.png
          1.08 MB
        5. 2014-08-16_08.42.02.png
          1.31 MB
        6. 2014-08-16_08.42.20.png
          1005 kB
        7. 2014-08-16_08.42.30.png
          1.18 MB
        8. 2014-08-16_08.42.38.png
          1.40 MB



            Unassigned Unassigned
            TitaniumTurtle TitaniumTurtle
            1 Vote for this issue
            1 Start watching this issue