Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-65394

Flower hitbox is broken and flowers are hard to target.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 14w31a
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed

      Description

      MC-3073 and MC-48362 and MC-51350 are all closed as duplicates of
      each other, but this is not resolved.

      Issue: Flowers spawn/grow/place off the center of the block they are on, but the hitbox does not adjust. This causes some flowers to be near impossible to pick.

      Observed in 1.8 snapshots up to 14w31a. See http://youtu.be/rlpEBRLMrT8
      This bug is more than just an annoyance of the hitbox being slightly offset, I first became aware of it because some flowers couldn't be broken until you targeted off the flower.

      Notice in the video that the hitboxes for all flowers (that I could find in survival) are offset from the flowers themselves. The hitbox can be off either way on the X or Z axis and can be so far off that it's hard to target flowers (see poppy in the video.)

      I noticed this comment in MC-48362:
      > [Mod] Anon Ymus added a comment - 13/Feb/14 4:48 PM
      > Being off-center is intended, but the hitbox can't be placed to match it.

      This implies that flowers are placed randomly offset from the center of the block they are on and the hitbox is not moveable. if this is the case, the hitbox should be expanded to compensate for variable placement.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                Kollins Darin Triplett
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: