Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-59723

Most command arguments don't work in the 1.8 snapshots

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Cannot Reproduce
    • Affects Version/s: Minecraft 14w21b, Minecraft 14w26b, Minecraft 14w26c
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Java 7 update 55, Windows 7 Operating System, 500 GB ROM, 4 GB RAM
    • Confirmation Status:
      Unconfirmed

      Description

      What I EXPECTED to happen was...:
      -In ANY snapshot for 1.8, starting as early as snapshot 14w02a, the first 1.8 snapshot, the command will work properly. When a command block with this command in it:

      testfor @p[r=1]

      is powered, it can detect a player less than one block away from the command block (especially noticeable by checking the comparator next to the command block.) This is how it works if you try it in 1.7.4, but not in the snapshots for 1.8.

      What actually happened was...:
      The command block, when given this command:
      testfor @p[r=1]
      and then powered doesn't detect a player if there is one close enough, and returns this result:

      "The entity UUID provided is in an invalid format"

      This problem happens using almost any command, and any argument. The exact same commands worked in the older versions, but this bug impairs players' ability to use commands in the snapshots. Nowadays, I can hardly do anything involving arguments due to this bug. The only thing I found that works is if I just write the coordinates, followed by the radius, without actually labeling the arguments, like so:

      testfor @p[682,10,43,r=1]

      And sometimes even that won't work either. Relative coordinates don't often don't work at all, except for sometimes with the execute command. The same result happens every time I try to specify arguments: the last output in the command block is "The entity UUID provided is in an invalid format," even though I have it perfectly written, and I've checked it for accuracy.

      This happens almost every time, and with almost every command. It makes command block work almost impossible. Please fix this bug soon, Mojang. Commands are made to be useful, not to refuse to work just because of some bug that prevents them from doing so. Please, I really like the snapshots, but almost nothing is do-able in them while this bug is present.

      Steps to Reproduce:
      1. Place a command block
      2. Place a redstone comparitor facing out from the command block
      3. In the command block, type the following:

      testfor @p[r=1]

      4. Get a button from creative mode, hold your crouch key down (the default is left shift) and right click the command block to place the button on it.
      5. Push the button on the command block.
      6. Right click the command block while in creative, and look at the "Previous Output field." The previous output will be listed as the time the command was activated, and then this error message:

      "The entity UUID provided is in an invalid format."

      7. Repeat steps 1-6 in Minecraft 1.7.4, and the comparator will output successfully if a player is within one block of the command block, though as a side note the previous output will not indicate its success, only the comparator will. The previous output will most likely be the time and then: "That player cannot be found," even though it obviously DID find the player if the comparator lit up when the player was within one block of the command block.

      As above mentioned, here is an example command, one that is extremely simple and correct, but doesn't work because of this bug:

      testfor @p[r=1]

      This bug only appears in command blocks, not in the chat.

      Try it for yourself. Run the example command in the snapshots. You'll see that I'm right.

      Here are three more examples, all of which have been double-checked for accuracy, but none of them work right now in the snapshots for 1.8 because of this bug of command arguments being mistaken for UUIDs:

      testfor @p[x=-535,y=4,z=-250,r=2] ~-0.2 ~-1 ~0

      scoreboard players set @p[score_necromancy_min=3,score_necromancy=3] checkpoint 4

      testfor @p[score_bloodlustmem=0]

      [Note: Both of the objectives mentioned above, necromancy and bloodlustmem are dummy objectives. To test them, you'll have to make the dummy objectives of the same name in your worldsave before running these commands.]

      Several other users already posted similar bug reports for this kind of issue. Their error reports were either ignored, or marked as "Works as intended." I don't know how making it so almost no command block stuff can be done could possibly be considered "Works as intended." This bug has been around since the start of the 1.8 snapshots, and nothing has been changed to improve this since then. Personally, I consider this to be the worst bug currently in the game, because it cripples adventure map/challenge map making.

        Attachments

        1. 1.7.4 inside command block.png
          1.7.4 inside command block.png
          132 kB
        2. 1.7.4 outside.png
          1.7.4 outside.png
          126 kB
        3. 14w02a inside command block.png
          14w02a inside command block.png
          130 kB
        4. 14w02a outside.png
          14w02a outside.png
          126 kB
        5. 14w26c inside command block.png
          14w26c inside command block.png
          173 kB
        6. 14w26c outside.png
          14w26c outside.png
          223 kB
        7. 2014-06-30_22.34.18.png
          2014-06-30_22.34.18.png
          179 kB
        8. 2014-06-30_22.36.55.png
          2014-06-30_22.36.55.png
          613 kB
        9. 2014-06-30_22.36.57.png
          2014-06-30_22.36.57.png
          599 kB
        10. 2014-06-30_22.37.05.png
          2014-06-30_22.37.05.png
          407 kB

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              93castle Adam Ekstrom
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: