Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-56773

World does not load and consumes RAM

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.7.9
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows 7, and Java 7
    • Confirmation Status:
      Unconfirmed

      Description

      One of my worlds does not load. When I try to open it, the program does not stop loading and continuously takes up more and more memory in RAM (according to task manager). Other worlds, however, work without any issues. It may be relevant that there is a vertical chunk missing (like it did not generate), but I have been able to work around it and it has not caused problems for a while.

      I have attached a stack trace from a recent attempt to open the file that I forced to stop through task manager. Most notably, there is "File '[...]\.minecraft\assets\indexes\legacy.json' does not exist" at the beginning and repeated reports of "Wrong location! yp['Zombie' / [some #]" where "some #" increases and reaches a higher number the longer I allow the world to try to load (suggesting that this is the origin of a recursive issue).

      What I expected to happen was...:
      I tried to open up my main world

      What actually happened was...:
      It would not open and takes up more and more memory indefinitely.

      Steps to Reproduce:
      I have no Idea how to reproduce this, it only occurs on one of my worlds.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              dempsey112995 Joey Smiga
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: