XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 14w18a
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      MacBook Pro OS X
    • Confirmation Status:
      Unconfirmed

      Description

      I was working around In my 14w18a snapshot world...

      I was placing down some redstone and what I knew was going to happen was that the redstone would connect...

      But what actually happened is the redstone would not connect...

      How to trigger the bug:
      1. Go to snapshot 14w18a
      2. Place down Redstone dust in a + symbol.
      3. If they do not connect, that is the bug.

      I was thinking, 14w18a had been worked on for a while so I thought some minor bug like this would be fixed but it MAY be a new bug... I tried to get a screenshot but the game crashed when I loaded it on 14w18a.

      Here's the crash report:

      (Try solving the redstone bug first though...)
      ---- Minecraft Crash Report ----
      // I let you down. Sorry :(
      
      Time: 4/30/14 9:15 PM
      Description: Rendering entity in world
      
      java.lang.NullPointerException: Rendering entity in world
      	at cce.a(SourceFile:79)
      	at cce.a(SourceFile:53)
      	at cce.a(SourceFile:24)
      	at cbt.a(SourceFile:219)
      	at cbt.a(SourceFile:199)
      	at cbt.a(SourceFile:176)
      	at bxs.a(SourceFile:495)
      	at bxl.a(SourceFile:1146)
      	at bxl.b(SourceFile:937)
      	at bjf.ai(SourceFile:828)
      	at bjf.f(SourceFile:755)
      	at net.minecraft.client.main.Main.main(SourceFile:121)
      
      
      A detailed walkthrough of the error, its code path and all known details is as follows:
      ---------------------------------------------------------------------------------------
      
      -- Head --
      Stacktrace:
      	at cce.a(SourceFile:79)
      	at cce.a(SourceFile:53)
      	at cce.a(SourceFile:24)
      
      -- Entity being rendered --
      Details:
      	Entity Type: ItemFrame (uh)
      	Entity ID: 33
      	Entity Name: entity.ItemFrame.name
      	Entity's Exact location: 673.50, 17.50, -552.97
      	Entity's Block location: 673.00,17.00,-553.00 - World: (673,17,-553), Chunk: (at 1,1,7 in 42,-35; contains blocks 672,0,-560 to 687,255,-545), Region: (1,-2; contains chunks 32,-64 to 63,-33, blocks 512,0,-1024 to 1023,255,-513)
      	Entity's Momentum: 0.00, 0.00, 0.00
      	Entity's Rider: ~~ERROR~~ NullPointerException: null
      	Entity's Vehicle: ~~ERROR~~ NullPointerException: null
      
      -- Renderer details --
      Details:
      	Assigned renderer: cce@24e28347
      	Location: -10.38,0.49,16.59 - World: (-11,0,16), Chunk: (at 5,0,0 in -1,1; contains blocks -16,0,16 to -1,255,31), Region: (-1,0; contains chunks -32,0 to -1,31, blocks -512,0,0 to -1,255,511)
      	Rotation: 0.0
      	Delta: 0.7339136
      Stacktrace:
      	at cbt.a(SourceFile:219)
      	at cbt.a(SourceFile:199)
      	at cbt.a(SourceFile:176)
      	at bxs.a(SourceFile:495)
      	at bxl.a(SourceFile:1146)
      
      -- Affected level --
      Details:
      	Level name: MpServer
      	All players: 1 total; [bxb['USAProsecutor'/34, l='MpServer', x=683.88, y=17.01, z=-569.56]]
      	Chunk stats: MultiplayerChunkCache: 81, 81
      	Level seed: 0
      	Level generator: ID 01 - flat, ver 0. Features enabled: false
      	Level generator options: 
      	Level spawn location: 644.00,4.00,-521.00 - World: (644,4,-521), Chunk: (at 4,0,7 in 40,-33; contains blocks 640,0,-528 to 655,255,-513), Region: (1,-2; contains chunks 32,-64 to 63,-33, blocks 512,0,-1024 to 1023,255,-513)
      	Level time: 405592 game time, 88184 day time
      	Level dimension: 0
      	Level storage version: 0x00000 - Unknown?
      	Level weather: Rain time: 0 (now: false), thunder time: 0 (now: false)
      	Level game mode: Game mode: creative (ID 1). Hardcore: false. Cheats: false
      	Forced entities: 12 total; [yj['Pig'/17, l='MpServer', x=630.16, y=16.00, z=-546.19], ya['Chicken'/16, l='MpServer', x=633.72, y=16.00, z=-548.56], bxb['USAProsecutor'/34, l='MpServer', x=683.88, y=17.01, z=-569.56], yj['Pig'/19, l='MpServer', x=625.97, y=16.00, z=-559.97], ya['Chicken'/18, l='MpServer', x=634.81, y=16.00, z=-552.28], uh['entity.ItemFrame.name'/33, l='MpServer', x=673.50, y=17.50, z=-552.97], ya['Chicken'/21, l='MpServer', x=635.56, y=16.00, z=-534.66], zg['item.item.egg'/20, l='MpServer', x=634.22, y=16.00, z=-552.63], zg['item.item.egg'/23, l='MpServer', x=635.88, y=16.00, z=-533.91], yc['Horse'/22, l='MpServer', x=629.00, y=16.00, z=-536.69], zk['container.minecart'/29, l='MpServer', x=655.50, y=16.00, z=-555.53], yk['Sheep'/30, l='MpServer', x=653.97, y=16.00, z=-508.03]]
      	Retry entities: 0 total; []
      	Server brand: vanilla
      	Server type: Integrated singleplayer server
      Stacktrace:
      	at buw.a(SourceFile:308)
      	at bjf.b(SourceFile:2069)
      	at bjf.f(SourceFile:764)
      	at net.minecraft.client.main.Main.main(SourceFile:121)
      
      -- System Details --
      Details:
      	Minecraft Version: 14w18a
      	Operating System: Mac OS X (x86_64) version 10.6.8
      	Java Version: 1.6.0_65, Apple Inc.
      	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.
      	Memory: 83351888 bytes (79 MB) / 186892288 bytes (178 MB) up to 1065025536 bytes (1015 MB)
      	JVM Flags: 1 total; -Xmx1G
      	IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
      	Launched Version: 14w18a
      	LWJGL: 2.9.1
      	OpenGL: Intel HD Graphics 3000 OpenGL Engine GL version 2.1 APPLE-1.6.42, Intel Inc.
      	GL Caps: Using GL 1.3 multitexturing.
      Using GL 1.3 texture combiners.
      Using framebuffer objects because ARB_framebuffer_object is supported and separate blending is supported.
      Anisotropic filtering is supported and maximum anisotropy is 16.
      Shaders are available because OpenGL 2.1 is supported.
      
      	Is Modded: Probably not. Jar signature remains and client brand is untouched.
      	Type: Client (map_client.txt)
      	Resource Packs: [SimpleCraft_V13.8]
      	Current Language: English (US)
      	Profiler Position: N/A (disabled)
      	Anisotropic Filtering: Off (1)
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              USAProsecutor Brian Caples
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: