Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-42835

Flowing water placed on wrong position and not removed (glitch)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.7.2, Minecraft 1.7.4
    • Fix Version/s: None
    • Labels:
    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Survival

      Description

      Second description:
      In survival mode, holding shift (sneak) does not select/focus the blocks as far as in creative mode.
      Pressing shift to move focus from a closer one to a further one will result in having no focused block but placing water is still possible.

      Placing water in such a case:
      An initial algorithm decides placing the water on the further block but a monitoring algorithm cancels the first decision and is placing again the water on the near block. The flowing water in background is not removed and is not being updated. It is possible to swim or drown in the "glitched" water. Reloading the world will remove the block.

      In same setup, if is possible to select the further block (by moving the cursor to the closest corner) then the flowing water is removed fast (is visible just for a short time) and relocated on the new closer position.

      Added additional pictures.

      Original first description.
      See attached pictures to understand description.
      Set the focus on the cobble stone, on the lower side close to to the diamond block in background. Holding shift, the focus will point to the diamond block.
      Try to put and retrieve fast a bucket of water (to turn lava into obsidian).
      The water is placed on the cobble stone and removed but a water animation remain in the background until the world is reloaded.

      Remarks:
      The glitch has nothing to do with lava. The water never comes close to lava during the experiment. I used obsidian instead of lava with same result.
      The glitch is 100% reproducible with this particular configuration of blocks.
      I stand on the redstone block and the diamond block is suspended above lava. When I tried in creative with an inexact replica, staying closer and diamond block inside the wall, but same concept as described with shifting, in that case the water animation in the background was visible just for a short time and was removed when the bucket was used second time to retrieve the water.

      I found it first on 1.7.2 in survival and reproduced it in creative on both 1.7.2 and 1.7.4.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              menzagitat Ioan Vira
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: