Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-39201

Mouse buttons stop working after activating Mission Control

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Minecraft 1.7.2
    • None
    • None
    • Mac OS X Mavericks, Java 7u45
    • Unconfirmed
    • Survival

    Description

      I was walking around punching some trees in amplified mode successfully after updating to 1.7.2, when I thought I would have a look at my framerate to see how taxing amplified terrain is.

      So I tried to hit Ctrl-F3, but I had forgotten that my keyboard wasn't set to use F keys by default (I was supposed to also hold down Fn.) So by accident, I had actually activated "Application windows" in Mission Control (also bound to F10 by default.)

      On returning to Minecraft, I couldn't stop punching the tree.

      I hit Esc to get to the menu to try and reconnect and found that it wasn't possible to use the mouse there either - I was stuck in the game.

      On going back into the game, I wasn't punching the tree any more, but I couldn't punch anything any further. Game over. :>

      I thought it was nuts, so I tried it again from the top and it turns out to be completely reproducible on my computer. That said, this is my work computer, so I will try again some time on my home one.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              trejkaz Trejkaz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: