Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-29414

The Wither Refuses Riding any entity, Even when forced through NBTediting

    XMLWordPrintable

Details

    • Bug
    • Resolution: Duplicate
    • None
    • Minecraft 1.6.2
    • None
    • Unconfirmed

    Description

      I though of a Mob that shows his health to use it as a tank, i had 2 choices, the enderdragon and the wither, and obviously the enderdragon is a bad choice, so i chose the wither.

      Later, i made him ride an invisible invulnerable zombie following a villager to make his defined path, but i couldn't get him to ride the zombie using an Mcedit filter, i thought it was something wrong with MCedit, so i switched to NBTedit and created the Tag "Riding "with all the required options for an invulnerable zombie, and made a spawner for him.

      when i spawned him though, it looked to me as if he was riding the zombie, so i tried to shoot him, but apparently he was only above the zombie, not riding him, i tried spawning another one and the same happened.

      Mojang please fix this, i highly depend on Mojang to fix this so my map works .

      EDIT: this might seem like a Duplicate but it is not, the other guy tried getting him into minecarts, which is something mojang removed to prevent abusing the wither by spawning him into a minecart and killing him inside it. the code however, prevents him from riding ANY entity even through NBTediting and third party programs.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              TheBroThatPlays george defented
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: