Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-271178

Nothing loads/placed in void when entering spectator mode upon death


    • Icon: Bug Bug
    • Resolution: Duplicate
    • None
    • 1.20.5
    • None
    • OS: macOS
      1.20.5, vanilla
    • Unconfirmed
    • (Unassigned)


      This bug seems to affect hardcore worlds.

      Upon death in a hardcore world, the normal "You died!" screen appeared, with the options to spectate world or save and quit to title. I clicked the spectate world option, but after doing so I was put in a void that only seemed to consist of the sky texture/sun. No blocks or terrain, no entities or mobs, no clouds, nothing. I tried using /gamemode spectator and /tp , but I just got an error message (I know close to nothing about commands). When I checked the F3 menu, I saw that my coordinates were near 0, 0; I decided to fly to those coordinates to see if any spawn chunks were visible, but none were. The same result happened after exiting the world, quitting Minecraft, and reentering. I've created a couple hardcore worlds, and the bug occurs consistently across them.

      Steps to reproduce:

      1. Create a hardcore world.
      2. Die in some way, whether by fall damage, mobs, etc.
      3. Select "Spectate world" when presented with the death screen.
      4. Observe surroundings. (Should be in void, free of any terrain or entities.)


      The screenshot with the F3 menu open is the last screenshot I had taken on a recent hardcore world (just to remember the coordinates of the shown villages/cherry blossom biome). The other screenshot was taken after clicking "Spectate world" and attempting a command which I evidently don't know how to do.

            Unassigned Unassigned
            _gh0stz_ _gh0stz_
            0 Vote for this issue
            1 Start watching this issue