Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-252028

Villager refuses to restock his trades post-zombification


    • Icon: Bug Bug
    • Resolution: Duplicate
    • None
    • 1.19 Pre-release 1
    • None
    • Unconfirmed
    • (Unassigned)

      I've tried every trick and remedy for this (villager not restocking) that is currently known and none of those worked, these include but are not limited to giving it more space, giving it less space, giving it free rein to the entire village, sleeping the night, and re-zombification. None of these worked so I went to the NBT data of the villager and found that it could not find the job site it was given; this is something I have seen on a previous bug report, but when I tried manually adding the job site to the villager it did not work. So maybe this is something I need to do on NBT explorer I thought, but I could not find the file for my villager anywhere; I found hundreds of other villagers, even the one other villager who still had their freedom but not my villager. I think it may be a problem entirely connected to zombification because these problems did not occur pre-zombification. Keep in mind I am new to the concept of NBT editing and editing entity files so I could be wrong, but I see no other reason as to why this might be happening.

            Unassigned Unassigned
            AlphaFlamingo AlphaFlamingo
            0 Vote for this issue
            0 Start watching this issue