Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-2378

Impossible to swim to the surface while in certain blocks of water.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.4.3
    • Fix Version/s: None
    • Labels:
    • Environment:

      Windows Vista Ultimate 64-bit, Java 1.7.0_09

    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Survival

      Description

      This occurs only in certain regions under water which I assume to be random. Once one of these locations under water is found, you'll find there is no way to swim upwards towards the surface like you usually do, and you will most likely drown due to this.

      This has happened to me twice so far since I installed the 1.4.3(prerelease).
      The first time it happened to me I used a waterfall which fell into a hole in the ground. The waterfall was about thirty blocks high. Once I had finished doing what I went in there for I found out that for some weird reason while I was trying to climb this same waterfall to get out of there, I could just raise up to about the middle of the height of the waterfall; and even though I was pressing the right keys which got me all the way to the middle, I just couldn't get any higher than this point. It seemed as if the key I use to swim upwards had broken, although I know this wasn't the case because as soon as I let go of it the waterfall would drag me down. So I really wanted to get out of this cave so I kept trying until I got dragged to a very low point in the water by the current, and my keys simply weren't responding and I drowned. This has never happened to me before 1.4.3(prerelease), and I've done a lot of swimming and waterfall climbing!

      In the end, I restarted minecraft hoping that maybe this would make the problem go away somehow, and then returned to the same cave to pickup my items by means of digging new holes so I wouldn't get stuck and drown again. I then tried to get out again by climbing the waterfall but the same problem persisted so I ended up just digging my way out through dry blocks.

      I thought this was really weird but since it had never happened to me I just kept on playing and forgot about it. But then the next day when I played minecraft again the same thing occurred a second time but in a different place. This time there were no currents/waterfalls, it happened in a small rectangular pond 2x10 and just 3 blocks deep. I went in to collect a piece of sugar cane that had fallen in when I tried to harvest it. To my surprise I was pulled to the bottom and my swim key seemed to be ignored again. I then desperately tried breaking a nearby block to somehow escape but it was too slow. I only had about five hearts left left when I noticed that at least I could strafe in the bottom and so I strafed on the bottom by about a block or two and thankfully, although I still was on the bottom, my swim key seemed to be responding again the more i tried to strafe to another are of the bottom until I was able to escape, although I was very close to drowning again.

      I'm absolutely sure that this has nothing to do with my keyboard. Some piece of code is making minecraft ignore the swim-up command in certain areas in the water.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                noblessus noblessus
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: