Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-235720

Can't connect to some multiplayer servers: io.netty.channel.abstractchannel

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Resolution: Duplicate
    • 1.17.1
    • None
    • Windows 10 Home 64 bit (10.0, version 19043)
      Intel Core i5-3470 CPU @ 3.20GHz (4CPUs), ~3.2GHz
      DirectX 12
      NVIDIA GeForce GTX 1070 Ti
      ~16GB DRAM
    • Unconfirmed
    • (Unassigned)

    Description

      When logging into minecraft a few days ago, upon trying to join a multiplayer server i was presented with the message: io.netty.channel.abstractchannel$annotatedconnectexception: Connection timed out: no further information: purityvanilla.com/94.130.174.66:25565

      (Purityvanilla.com being the server i was trying to join) This message appeared on multuple other servers too, but not all of them. I know it's a known problem, but none of the solutions i've found have worked:

      Renewing dns in the command prompt, reinstalling minecraft, reinstalling java, turning off the firewall.

      Some weird things that happened were that after reinstalling minecraft, none of the servers worked anymore. Weird, considering i hadn't changed anything. But after that i went into the firewall and manually allowed all Java(TM) Platform SE binary files that i could find inside of the Java folder through the firewall. This somehow worked. I didn't do anything else afterwards, but when i turned on the computer the next day, some servers stopped working again. (Namely hypixel, mineplex and purityvanilla)

      I've spent countless hours trying to figure out what the problem is. One thing i found was that the programs Hamachi and Adw Web Companion could apparently cause problems with Minecraft multiplayer. I deleted these programs via the control panel, but the problem persisted.

      I read somewhere that a possible solution to the problem could be to manually let the server ip through in some way. But that requiers going into the "Minecraft Server" folder and i have no idea where that folder is.

      Please help me out if you have any clue on what the problem could be. 
      (EDIT: I don't know if this is the right place for this problem, but i just found this website while looking for solutions. Please just don't dismiss my problem just because i'm in the wrong place, i really need help from people who know more than me)

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              Eshosh Elis M
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: