Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-19896

Font messed up + some animations broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.6, Minecraft 1.6.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      doesn´t matter
    • Confirmation Status:
      Unconfirmed

      Description

      Hi,...

      ... so... I downloaded the new 1.6 PR... as well as the Tool for converting older TPs to the new Resource pack format...

      all went good... I ran the game after converting my TP into a resource pack, selected it in the game... loaded... nice and fine. logged into the game... all worked... except the furnace animation... it loaded with purple/black squares...

      I quit the game, checked the animation properties files... it was present... I compared it to the other ones I have... all seemed same and fine...
      ... I logged back to the game...

      And at once the font was completely messed up, unreadable, totaly faulty loaded or what...

      the animations are not working properly... I have all the properties files set up correctly? (as they worked in 1.5.2) - if not... feel free to link me to a place where this mess is clearly explained as I am getting already ed on from changing it every release nearly...

      what is the issue?
      ANIMATIONS

      • ie. fire, flowing water, custom animated rs lamp in on state, all work fine but... the portal animation works as if slowed/laggy... and directly opposite to this the ie. Furnace in on state works far too quickly...
      • I have setup the framerate to 2, but still it runs at full speed ignoring it or I dunno... but the furnace animation flickers simply too fast...

      FONT

      • the font is totaly messed up and unreadable...
      • when I switch the language the default font loads which seems fine... when I switch back to my HD font, it is again unreadable...

      SCREENSHOTS
      missing text from enchanting table + unreadable fonts/tooltips...
      http://i40.tinypic.com/2isjr5x.jpg
      http://i40.tinypic.com/33z89xh.jpg
      http://i43.tinypic.com/sgpdu0.jpg

      Furnace on right is animated... should be...
      http://i40.tinypic.com/nd4x2c.jpg

      VIDEO
      http://www.youtube.com/watch?v=BY4qxEYkYt0

      Exactly same happened today... when I made this screenshots and video about this...
      I ran the new launcher... I noticed there is a newer version available 1.6.1 ... logged in... and voi la all Fonts worked as they should... full HD, nothing messed up... logged into the game... everything was alright. (except the furnace, which was flickering faster as it should - but it was due to the fact the properties file had not specified the framerate - as when I do... it loads the texture with purple/black square) O_o

      So I already wanted to abandon this report I am writing now... but then... I quit the game and went over to the resource pack to add the framerate for the furnace animation to work corretly...
      I logged back into the game and BAM! ... All fonts have been messed up again...

      So I have really no idea WTH is wrong... but it loads always fine for the first time and after that it loads messed up everytime... no matter if I change the Resource pack, no matter if I recreate the resource pack...

      **EDIT**
      ok... I just noticed the messed up font is even in the DEFAULT resource pack ( I switched from my "TP" to the default to see if the issue will persist... and yes... it did... thus it is not just about HD fonts... but fonts generaly)

      • @Furnace
        I think I was able to make the furnace work as intended... by adding to the properties file number of frames as well, and not just framerate multiplier.

      So the font remains the only issue...

        Attachments

        1. 2013-06-30_14.17.01.png
          2013-06-30_14.17.01.png
          575 kB
        2. 2013-06-30_14.17.04.png
          2013-06-30_14.17.04.png
          176 kB
        3. 2013-06-30_14.17.37.png
          2013-06-30_14.17.37.png
          1.39 MB
        4. 2013-06-30_14.17.47.png
          2013-06-30_14.17.47.png
          495 kB
        5. 2013-06-30_15.17.12.png
          2013-06-30_15.17.12.png
          259 kB

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                babbajagga Norbert ofcNOT
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: