Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-18200

Horse runs away. Player appears dismounted, player is still affected as if still mounted

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Snapshot 13w24b
    • Fix Version/s: None
    • Labels:
    • Environment:
      Windows Vista, Java 7, update 21 (build 1.7.0_21-b11)
    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Survival

      Description

      While riding a horse, I hit the jump key (which I map to the z key in options). I appeared to dismount but the horse galloped in the direction we had been headed by itself.

      As I was following it, I noticed my health bar was indicating I was talking damage although I couldn't see the source of the damage. Happened a few times. After about a minute, I was suddenly teleported into a cave where the horse was milling about and I was taking a suffocation damage although I couldn't see the source of the damage and was still moving about independently of the horse. Then I died.

      The horse was wearing a saddle and iron armor.

      I reloaded the save (for incidental reasons, I restarted Minecraft first) but I could not reproduce this issue. Jumping on a horse worked fine. I tried with and without the horse armor. The only time I could reproduce getting forcibly dismounted as by going in water. I had to build a bridge underneath the horse to regain control of it.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jeb [Mojang] Jeb (Jens Bergensten)
              Reporter:
              jeffmagill Jeff Magill
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: