Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-18036

Game crashes after changing resource pack

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Snapshot 13w24b
    • Fix Version/s: None
    • Environment:
      OS: Windows XP (ver 5.1, arch x86)
      Java: 1.7.0_21 (by Oracle Corporation)
      Launcher: 0.9.3 (Dev) (bootstrap 3)
      Minecraft: 13w24b (updated Fri Jun 14 08:54:59 CDT 2013)
    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Creative

      Description

      While working on a contest entry in a new creative superflat world using the latest snapshot (13w24b), I changed from the customized resource pack I'm using (a modified version of Rhodox's Painterly Pack) back to the default resource pack. I clicked the done button and went back to the game menu. However, clicking the back to game button resulted in the game shutting down.

      After reloading the game, I went through the same series of steps, trying to see if it was only triggered by going to the default resource pack, but changing it to my custom pack still crashed it. Tried repeating it several times and each resulted in a crash.

      The game only crashes, though, when I change the pack. If all I do is load the resource pack menu and click done without changing, the game will work properly. It's only changing packs that causes the crash.

      I tried changing the pack from the main menu, and had the game crash once, but otherwise it seems as though it's stable and I couldn't get it to happen again.

      Steps to Reproduce:
      1. Load creative world with the 13w24b Snapshot installed
      2. Go to game menu>options>resource packs
      3. Change resource pack and go back to game menu
      4. Click the back to game button
      5. Game crashes

      EDIT: Looked around for a similar bug report and couldn't find one that fit the same criteria as this. Haven't tried to reproduce the crash in another game mode, so I'm not sure if this is happening for ALL game types, or just creative.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              Pandaikon0980 Pandaikon0980
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: