Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-179959

Crash for World -> Edit -> Optimize World


    • Icon: Bug Bug
    • Resolution: Duplicate
    • None
    • 20w17a
    • None
    • win7x64, java version bundled with Minecraft
    • Unconfirmed

      Put the summary of the bug you're having here
      In world selection choose a 1.16 world, click EDIT, click OPTIMIZE WORLD, click I KNOW WHAT I'M DOING

      What I expected to happen was...:
      The optimize world screen would appear and the game would "do it's thing"

      What actually happened was...:
      The game crashed

      Steps to Reproduce:
      1. I had created a test 1.16 world when the first snapshot was available
      2. After starting the game under 20w17a I noticed a beacon was not working
      3. The beacon worked once I broke and replaced the beacon block
      4. >>> I do not know if the above has anything to do with this bug <<<
      5. I saved the game and restarted it to make sure the beacon was still working – it was
      6. I thought that perhaps there were some changes in 20w17a that might require any old data to be updated, so...
      7. I saved the game
      8. From the PLAY menu, I selected this world again
      9. I clicked EDIT
      10. I clicked OPTIMIZE WORLD
      11. I clicked "I KNOW WHAT I'M DOING"
      12. The game crashed

      I tried with ERASE CACHED DATA checked and unchecked. The game crashes in both cases and the crash dump files are essentially the same

            Unassigned Unassigned
            CJock Dave B
            0 Vote for this issue
            0 Start watching this issue