Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-173594

Server error with commands and command blocks.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: 20w09a
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Version: Snapshot 20w09a, Vanilla Minecraft Server (Datapacks), Windows 10 laptop
    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      Of course, this being a snapshot, I'm not surprised this error is popping up. It's not even an error message, it's just a weird glitch or bug that prevents me from doing cheat/OP commands as an administrator on my own server. I'm even OP on it. 

      So, the issue is that every time I set up a custom command with /trigger functions (like /trigger spawn) I suddenly start getting problems with admin commands. I use command blocks for these trigger commands. I used this specific tutorial as well:

      https://www.youtube.com/watch?v=FzTvN7yYft4

      It worked so far until I used an admin command. The server crashed and admin commands are wonky, and have to be spammed for a little bit before working. After the first try an error that says "An unexpected error occurred trying to execute that command" comes up. I restart the server and admin commands work (85% of the time anyway) except for /op. It works if you do it twice, but it always starts with "An unexpected error occurred trying to execute that command." This also appears in the console when I type out these commands.

      Now, the admin commands aren't the only issue. Another issue is that command blocks can't be opened. I turned down spawn-protection to 0, I set enable-command-blocks to true, and made sure I was OP and in creative mode. Still, nothing works. I tried to let my admin work it out, but even they can't do it. 

      I made sure to test if the datapacks I installed were the problem but they aren't. I downloaded anti creeper grief, anti ghast grief, kill empty boats, more mob heads, multiplayer sleep, player graves, set home, and custom villager shops.

      Datapack site: https://vanillatweaks.net/picker/datapacks/ The datapacks work, and don't show any sign of being the cause. It's the trigger commands. Idk why creating a trigger nearly destroys the server...

      Hopefully this was enough info for this bug to be resolved...

      I sadly have no sources to send this issue. (Right clicking the command block doesn't work either...)

      If you need me to record proof of not being able to right click/open command block GUI prompts, let me know.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              Zatiejo_ Zatha Long
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: