Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-157335

Shield appears like it's not blocking if you still hold use after blocking damage.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: 1.14.4
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      It's just a visual bug, yet it's very infuriating and confusing. For example, a skeleton shoots and you block the arrow while still holding the 'use' button. Now the shield seems like it's not blocking though you still move slower and it still blocks damage.

      What I expected to happen: the shield still showing the blocking animation after blocking damage.

      What actually happened: the shield appears as if it wasn't blocking, yet still blocks and makes you move slower.

      Steps to reproduce:

      1- Hold 'use' button until you block damage

      2- Still hold the 'use' button even after blocking damage (sometimes takes multiple hits).

      3- (optional) Hold it until something tries to harm you again. You'll see how it still blocks.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              Flaitastic Flaitastic
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: