Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-154938

Villager trades me wrong enchanted book when I try to trade with him

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.14.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      I am in a vanilla server for 1.14.2. I run Minecraft Java on a Windows 10.
    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      I found a wild villager at a nearby village. I wanted it to be a librarian so I could get my desired enchantment(Unbreaking). I used a zombie to turn him into a zombie villager. I cured him, and grinded by mining and placing a lecturn over and over until I got unbreaking 2. I went to trade with him until he was maxed out, so I got around 10 books of unbreaking 2. He got more trades when I traded with him some more, and he also traded knockback 2. I didn't want this trade so I moved on. Later, a zombie pigman came through my portal. I killed it, but while doing so, I hit my villager with the sweeping edge. He increased the prices for some of his trades. Later, he accessed his lecturn and unlocked his trades. I went back to him for some more unbreaking 2 books, but when I went to purchase 2 unbreaking 2 books, he gave me 2 knockback 2 books. I realized this and went back to the villager. I traded with him 4 new times, each using different methods(clicking the trade its self, and putting in the items manually), and every time he sold me knockback 2. I even checked to see if the book was really unbreaking 2 in the small box where he shows me the item I was going to get when I confirmed the trade, and it did tell me that the book that I was going to get was unbreaking 2. But, when I clicked on the book, it changed into knockback 2 instantly. Both of the books costed 1 emerald and 1 book. After trying to get unbreking 2  6 different times, the knockback 2 trade locked up. The unbreaking 2 trade did not lock up, but even then, when I tried to get unbreaking 2, the villager would not take the trade, as if the unbreaking 2 book was also locked up. The villager has not accessed it's workbench after that, and his trades have not reset. It has been well over 30 minecraft daylight cycles. I am in a server, but it is vanilla, and there was no lag when I was trading. I checked thoroughly to make sure I was getting the right book and I concluded this was likely a bug. I even talked to the owner who told me that they didn't implement anything that would affect villagers. I was unsure where I could talk about this so I came here just to be safe. I was very specific just in case if the bug could be replicated.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              _Pineapp1e_ Garrett Garcia
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: