Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-151363

Issues upgrading map from 1.13.2 to 1.14.X

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.14, Minecraft 1.14.1 Pre-Release 1, Minecraft 1.14.1 Pre-Release 2
    • Fix Version/s: None
    • Labels:
    • Environment:
    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      This bug is occurring when attempting to convert a map that was first generated in Minecraft version 1.13.2 over to 1.14 or any 1.14.1 prerelease:

      On the Debian Linux 8 server, the map will take forever to --forceUpgrade and --eraseCache, and when it finishes, it immediately spits out that it's running 2 seconds behind. Upon anyone joining the game, the server will crash within 1 minute of the player joining. If the joining player is able to make it into the game, they will not be able to do anything except stare at an empty horizon with a blank inventory. Another odd symptom of something being off is that the server console only says that it can load 6 recipes and 811 achievements.

      On the Desktop PC running Windows 10 and Minecraft in normal game mode (UI, no CLI), I select the option to upgrade the map to 1.14, then after the upgrade is finished, I spawn into it, but chunks don't load correctly. They either take forever to load or don't load at all. The game is also horribly laggy and slow to process things like blocks breaking, if they process at all. I assume that I'm able to at least partially load into the map because I have more RAM at play and I'm running in singleplayer on the desktop.

      Also of note is that I am able to generate a new 1.14/1.14.1-prerelease map using the same seed as the 1.13.2 world, on both the desktop and the server, and the same terrain from the old world will load in perfectly fine. I haven't been able to pin this on anything but a possible issue with the map upgrade system.

      The game is vanilla with no mods.

      I've tested the game with all player data deleted, but the same symptoms happen.

      Attachments are two screenshots from the Windows desktop client and a few crash reports from the Linux server.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                IceGT Ice Gotato
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: