Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-145256

Minecraft causing MacBook Pro to heat up, using up to 350% CPU

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.13.2, Minecraft 19w09a, Minecraft 19w11a, Minecraft 19w12b, Minecraft 19w13a, Minecraft 19w13b, Minecraft 19w14b, Minecraft 1.14 Pre-Release 2, Minecraft 1.14 Pre-Release 5, Minecraft 1.14, Minecraft 1.14.1 Pre-Release 2, Minecraft 1.14.3 Pre-Release 3, Minecraft 1.14.4 Pre-Release 2, Minecraft 1.14.4 Pre-Release 6, 1.14.4
    • Fix Version/s: None
    • Labels:
    • Environment:
      MacBook Pro (Retina, 13-inch, Early 2015)
      macOS Mojave 10.14.3
      Java 1.8.0_74
    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      While I'm not quite sure exactly when it started, I've been having this problem for several months now. When playing Minecraft, my computer heats up, and when I opened up Activity Monitor and looked at it while having Minecraft open, it uses around 300% when opening the game itself, in the menu it tends to go down to less than 100%, and then opening up a world and playing in it brings it back up to the 260-340% range. It then goes down to around 30-100% longer-term, but it still heats up about the same way as if I were playing a more resource-intensive game, loud fan sounds and all. Attempting to play in 19w09a had it more in the 120-150% range while playing, 19w13a had more of a range of 170-230%, and 1.14 Pre-Release 2 was more between 190-210%. 1.14.4 Pre-Release 2 had it in the 100-200% range depending on the size of the window. Personally, I find this to be an unplayable situation.

      I have all the video settings down as much as possible. Fast graphics, minimal particles, I even tried turning the render distance down to 2 chunks in 19w13b, and yet the issue persists. This was not a problem I faced in 1.12; on the contrary, the game ran splendidly with the fancy graphics, clouds, and particles on, and I remember the moment when that suddenly stopped being the case quite distinctly.

      As of April 20, I went and downloaded 1.12.2 again to test if maybe the issue was on my end, happened to have a world lying around in that version (mind, I would have created a new one if it hadn't been there), and set about the usual tests I've been doing with the 1.14 snapshots. Launched the game, kept Activity Monitor behind the Minecraft window, opened up the world, and the game ran as splendidly as I remembered. If anything, the launcher was using more CPU when I had the output log enabled. CPU stayed below 70% for the most part during play, even going as low as 36%. This was with the render distance at 6 chunks, fancy graphics, Version 2 of the new textures if that's relevant, and smooth lighting on. If the issue never gets fixed at least this version still works.

      From the last thread I found (and commented in a few days ago but it was marked as resolved so I thought I may need to report it myself), I saw screenshots of the Activity Monitor, as well as an instruction to force the game to crash and attach the crash report, so I went ahead and attached a crash report, a screenshot from opening the game, and a screenshot from playing in a creative superflat world. I also added a couple screenshots from a creative buffet world (badlands) after several minutes in it, as it has also been displaying the same behaviour upon opening that the superflat world does.

      Upon looking at which version of Java I had, I went ahead and downloaded it again. That may have made it worse; opening Minecraft peaked at 572%, and playing in the same world 300%. I have also added the crash report and two screenshots for this as well. The Java version appears to be the same from the crash report, and subsequent tests were in the previous range, so I believe it to be an outlier. More screenshots and another crash report can't hurt, though, right?

      I tried uninstalling and reinstalling the game. Twice. No dice. I did make sure I kept all my saves, but I only remembered to put them back after opening up the game post-reinstall both times and the same CPU thing was happening, so I think I can rule out world saves being the culprit. I also noticed something about an output log in the launcher settings when I was putting things back to the way I liked them, so I toggled that and took some screenshots, not sure if that's helpful.

      Someone else commented with the same issue. They said that the resolution used by the game in windowed mode is using the native resolution of the screen, which should not be happening. To verify that this was the case, I took in-game screenshots with F3 up. One was in the default-sized window, one was in fullscreen at a set resolution, and one was with the window taking up most of the screen. The third screenshot revealed that the resolution of the game was but 200 pixels shorter than the resolution of my screen, and thus I am under the impression that this is part of the problem, or at least exacerbating the one I first detected. Additionally, after exiting the game from playing in full screen, the Activity Monitor still shows Minecraft using about 90% CPU right before it updates (as I have the update frequency set to 5 seconds) so I do not believe the resolution is the sole culprit. It is, however, very frustrating to be unable to change the resolution in windowed mode when there is an option to change it for fullscreen mode.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                48844 48844
              • Votes:
                12 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Potential Duplicates