Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-13991

Player Loses Sync With Server After Trying To Mount A Horse In Water

    XMLWordPrintable

    Details

    • Confirmation Status:
      Unconfirmed

      Description

      I was experimenting with horses in the newest snapshot when I rode one into water that was 3 blocks deep. Doing this automatically removed me from the horse, and I tried to remount said animal a couple of times underwater. Doing so left me unable to place blocks and it made the system animate my character's lower torso as if I was still riding a horse. Saving and quitting the world resolves the issue, but transports me back to the point where I first tried to mount the horse.

      I made a video showing the phenomena here: http://www.youtube.com/watch?v=k9VCja2fGys
      (Skip to 2:20 to see the bug demonstrated.)

      Steps to Reproduce:
      1. Ride a horse into water more than 2 blocks deep. (I was in creative mode, I am not sure if this makes a difference.)
      2. Attempt to remount the horse several times while under water.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              andrewnprice Andrew N. Price
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: