Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-136780

Opening chat window inserts bound key into chat occasionally


    • Icon: Bug Bug
    • Resolution: Duplicate
    • None
    • Minecraft 1.13.1
    • None
    • Ubuntu 16.04 LTS
      Java 1.8.0_181 64bit (as reported in F3 debug screen)
      Dell XPS15 9560
      Both with optirun/bumblebee (ie, using Nvidia GFX) and without (ie, Intel onboard GFX)
      Vanilla (no mods)
    • Unconfirmed

      When pressing 't' to open chat, it will sometimes place a 't' in the chat box, which must then be backspaced. Will also do the same with '/' to open command, where it'll place an additional '/' in the chat box (making two).

      Rebinding the keys will maintain this behaviour, inserting the key that was pressed - ie, rebinding command to '[' then pressing '[' will occasionally open the chat box with '/['.

      Appears to be unpredictable but regular. Sometimes the bound character is inserted and sometimes it isn't, but seems like it'll be 20-50% of the time.

      Tried lots of versions to find where it first occurs, which appears to be in the 17w43a snapshot (the first after 1.12.2).

      Does not occur prior to 17w43a (tried 1.9.2, 1.12.2).
      Occurs in (17w43a, 1.13, 1.13.1).
      Occurs when system java is used directly and when wrapped to invoke optirun/bumblebee (to use discrete GFX card).
      Occurs in vanilla, and modded (such as optifine).
      Occurs in solo (creative and survival), and playing on public multiplayer servers.

            Unassigned Unassigned
            Phidaissi Ashley Waite
            0 Vote for this issue
            1 Start watching this issue