Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-135482

([DETAILED POST] Internal Exception players cannot join my server without being on LAN (ONLY 1.13)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.13
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Running Windows 10, Java 8 update 181 (64 bit), server on full default settings starting both with no .bat and also with a 4gb allocation.
    • Confirmation Status:
      Unconfirmed

      Description

      Hello, I've been running servers from my home internet for quite a while (many years) including dozens of minecraft servers in the past.

      My friends and I were trying to start up a new playthrough on 1.13, using the same port settings we had been successfully using just a day prior to run a modded 1.7.10 server, when we found that he could not join our server. The server showed up, as it was ported correctly, but when he tried to connect, loading terrain would show up for 5-10 seconds (much longer than usual), and he would get in game for about a second before being disconnected with the message "Internal Exception: java.io.IOException: An existing connection was forcibly closed by the remote host".

       

      We tried a lot of troubleshooting, checked to see if idle timeout settings had gone wrong (set to 0 , the default).

      Nothing worked, so I figured we ought to see if 1.7.10 still worked- and it did without issue. We then went through the updates to see which update it was where he could no longer connect. Everything through 1.12 worked just fine- I tested some of the snapshots- 1.13-pre5, and they failed too. So I don't know exactly where this issue began, but it was somewhere between 1.12 and 1.13-pre5

       

      Today I got the chance to try and log in on my laptop from a different connection, and found that I could not connect either- which confirms that it's server side and not just a problem on his end.

       

      I've yet to find anyone with the exact same issue as me, but I did find some similar issues:

      http://www.minecraftforge.net/forum/topic/65198-kicked-from-multi-player-server/

      https://www.minecraftforum.net/forums/support/server-support-and/2917715-only-2-people-able-to-be-on-server-at-once

      https://www.reddit.com/r/Minecraft/comments/93qc7g/ioexception_an_existing_connection_was_forcibly/

      TLDR;

      It is server side- people joining from the same internet connection as the host can join (myself, and my girlfriend were able to from my house), while anybody off of my internet could not (my friend in Texas and myself on a laptop not home).

      This issue began to occur on a version somewhere between 1.12 and snapshot 1.13-pre5, and occurs on all issues after pre5.

       

      Update-

      It seems that the disconnect message is inconsistent too. Now that I'm on a separate internet I can test this more thoroughly than my friend wanted to. 

      Messages I've received:

      Timed out

      Internal Exception: java.io.IOException: An existing connection was forcibly closed by the remote host

       one about a connection refused with java.io in there (forgot to screenshot it)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                Sgt_Sheep Anthony Mainiero
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: