Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-134466

Structure Block Outline Incorrect

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: Minecraft 1.13
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows 10, running latest version of Java
    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      I saved a structure block in a converted (1.12.2->1.13) world and it worked fine. However, when I was in the negative x position, the structures I saved would not save properly. I figured that it was a save issue because I tried to load the same structures in other worlds, with the same result. All of the structures with positive x coordinates worked fine, but this may just be a coincidence. The structure name is all lowercase (it is minecraft:tdmarena2a) so that is not the problem. I tested it with a couple different worlds (one normal, one void like the world I had the bug), but could not find anything that replicated the bug. The structures that don't work have armor stands in them, but so do the other structures in the world that worked.

      EDIT:
      I found out what was wrong, the white outline was in a completely different location than where it was saving. See new picture. So the problem is that the outline is in an incorrect position, title updated accordingly. The show air is what the structure actually saves, and the outline way away from it.

        Attachments

        1. How the Structure Loaded.png
          How the Structure Loaded.png
          441 kB
        2. Inside Load Structure Block.png
          Inside Load Structure Block.png
          363 kB
        3. Inside Save Structure Block.png
          Inside Save Structure Block.png
          1.57 MB
        4. Outline is Misplaced.png
          Outline is Misplaced.png
          239 kB
        5. Structure I Saved.png
          Structure I Saved.png
          3.62 MB

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              LegoBro Zayin Calvert
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: