Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-132340

Updating world will crash the game

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.13-pre5
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Microsoft Windows 10, Java 8

    • Confirmation Status:
      Unconfirmed

      Description

      Hi! I tried to update a map from 1.13-pre4, and the game has crashed. It had a data pack, but I tried without it, and the game still crash.

      ---- Minecraft Crash Report ----
      // You're mean.
      
      Time: 2018.06.29. 14:24
      Description: Exception in server tick loop
      
      java.lang.NullPointerException: Exception in server tick loop
      	at bta.<init>(SourceFile:13)
      	at btb.b(SourceFile:313)
      	at btb$$Lambda$1436/538048857.apply(Unknown Source)
      	at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)
      	at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)
      	at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)
      	at java.util.Iterator.forEachRemaining(Iterator.java:116)
      	at java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)
      	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:512)
      	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:502)
      	at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708)
      	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
      	at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499)
      	at btb.a(SourceFile:314)
      	at bnd.n(SourceFile:81)
      	at sx.p(SourceFile:591)
      	at sx.<init>(SourceFile:129)
      	at dej.a(SourceFile:97)
      	at dej.d(SourceFile:132)
      	at net.minecraft.server.MinecraftServer.run(SourceFile:505)
      	at java.lang.Thread.run(Thread.java:745)
      
      
      A detailed walkthrough of the error, its code path and all known details is as follows:
      ---------------------------------------------------------------------------------------
      
      -- System Details --
      Details:
      	Minecraft Version: 1.13-pre5
      	Operating System: Windows 10 (amd64) version 10.0
      	Java Version: 1.8.0_51, Oracle Corporation
      	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
      	Memory: 347843840 bytes (331 MB) / 520093696 bytes (496 MB) up to 1073741824 bytes (1024 MB)
      	JVM Flags: 9 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xss1M -Xmx1G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=16M
      	Profiler Position: N/A (disabled)
      	Player Count: 0 / 8; []
      	Data Packs: 
      	Type: Integrated Server (map_client.txt)
      	Is Modded: Probably not. Jar signature remains and both client + server brands are untouched.
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                Boti804 Boti804
              • Votes:
                2 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: