Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-132260

Game crashes on launch: Invalid axis in gamepad mapping

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Minecraft 1.13-pre5
    • None
    • None
    • I have an N64/SNES USB controller plugged into my computer.
    • Unconfirmed

    Description

      The game crashes on startup when I have a controller in my USB port.

      Crash report:

       

      Time: 28-6-18 19:10
      Description: Initializing game
      java.lang.IllegalStateException: GLFW error: [0x10004]Invalid axis in gamepad mapping 030000001008000001e5000000000000 (NEXT Classic USB Game Controller)
       at cez.u(SourceFile:130)
       at cez.<init>(SourceFile:69)
       at cey.a(SourceFile:82)
       at cep.am(SourceFile:415)
       at cep.a(SourceFile:358)
       at net.minecraft.client.main.Main.main(SourceFile:143)
      

      I tried it with different USB controllers: an SNES controller made the game crash too (same crash report), while it worked fine with an NES controller plugged in.

      This has never happened before and only occurs when launching 1.13-pre4 and 1.13-pre5. (I tested all 1.13 pre-releases and 1.12 versions)

       

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              ZekerMarco ZekerMarco
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: