Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-12681

Bow remains in hot bar despite breaking, the disappears later when trying to use it

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.5.1
    • Fix Version/s: None
    • Labels:
    • Environment:
      2010 MacBook Pro, OS X 10.8.3, Java SE 6 (1.60_43), 64-bit CPU
    • Confirmation Status:
      Unconfirmed
    • Game Mode:
      Survival

      Description

      I had a bow that was combined with Infinity I and Power V enchantment books using an anvil. I wanted to see if I could add more enchantments to it using the enchanting table, but when I put the bow into the table, it disappeared. It's gone forever.

      Update 1: I think I was way too vague in my description. It's worth mentioning that earlier, the bow didn't disappear after it's durability ran out. I heard the "break" sound, but the bow somehow reset itself as if it were brand new. I assumed that this was due to the Infinity I enchantment (Power V was not added until after). But if that was the case, then why bother having a durability bar on if it was meant to last forever? Perhaps this is related? The bow was probably meant to disappear after I used it up but didn't until I tried to enchant it with the Table. Delayed reaction, much?

      So here is the sequence of events that took place, leading to the bug:

      1. Found Infinity I book in a dungeon.
      2. Crafted a bow.
      3. Combined the book with the bow.
      4. Found the Power V book in another dungeon. Stored that away for later, not thinking it could be used on the bow, too.
      5. Used up the bow on a skeleton. Bow strangely resets itself, like it were brand new.
      6. Bring the bow back and combined Power V book with it. Renamed the bow as well.
      7. Got excited and tried to add more enchantments to the bow using the Enchantment Table. Bow disappeared when placed in the box.

      Update 2: So I tried to replicate the bug and I got a result very similar to what I had before.

      The bow reset itself after it broke. Yet this time, it disappeared when I right-clicked the anvil (to add the Power V enchantment).

      So yeah, I think the problem is a delayed reaction when the bow breaks.

      I'll come back after I try to see if the same problem occurs with a non-enchanted bow.

      Update 3: Okay, so non-enchanted bows are affected too. But this time I found the real problem.
      You hear the "break" sound, but it stays in your hand and your hot bar until you right-click for any reason.

      So my guess is that when I ran into the bug earlier, I may not have right-clicked the bow after it "reset" itself, I must have selected a different item in my hot bar at the time. Thus, the nonexistent bow remained there until I tried to use it on the enchantment table. Yet it was able to work on the anvil. (Though I probably didn't have it selected in the hot bar at the time.)

      Bottom line, the bow becomes a ghost after it breaks, enchanted or not. It stays in the hot bar and in your hand until you attempt to use it. You can mod it on an anvil granted it's not selected in your hot bar at the time.

      I changed the title to match the real problem.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              felipevonluigi Seth Parker
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: